activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Queue names with special characters
Date Wed, 22 Jun 2011 10:43:49 GMT
This looks like a bug. You can raise a Jira for it. Any contributions in
forms of patches and such are more then welcomed.


Regards
-- 
Dejan Bosanac - http://twitter.com/dejanb
-----------------
The experts in open source integration and messaging - http://fusesource.com
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, Jun 20, 2011 at 1:42 PM, Detlef Richter <
detlef.richter@de.rhenus.com> wrote:

> Hi there,
>
> I wanted to provoke a message on usable characters in a queue name and
> entered a name of "TEST&&123.4/5\66" into the "create queue" of the web
> interface.
> Was a bit surprised  when no message turned up and I really saw that name
> in
> the queue list!
>
> What was even more annoying was that I couldn't delete the queue using the
> "delete"-link. I had to url-encode the name by hand and modify the
> "delete"-link to be able to get rid of the queue.
>
> Is that a bug or a feature that such characters are allowed to be entered
> as
> queue name?
>
> And if allowed, shouldn't the web interface be modified to cope with these?
>
> Best Regards,
> Detlef Richter
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Queue-names-with-special-characters-tp3611157p3611157.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message