activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From danieldestro <danieldes...@gmail.com>
Subject Slave of ActiveMQ Cluster does not dequeue messages
Date Mon, 16 May 2011 15:16:04 GMT
Hello All.

Just downloaded ActiveMQ 5.4.2 and tested its cluster mode on my development
workstation (PC with Ubuntu Linux 10.04) and it worked fine. Configured
Master to port 61616 and web console to port 8161. Configured Slave to port
62626 and console to 8262. Both on the same IP. I tested all possible
scenarios I can imagine and it worked fine with a Java JMS Queue producer /
consumer.

I used this approach (Pure Master/Slave):
http://activemq.apache.org/pure-master-slave.html

Installed (unziped) ActiveMQ 5.4.2 to my production server (Red Hat
Enterprise Linux 4 64 bits - jdk 1.6.0_06) and configured (activemq.xml)
Master on IP 10.198.14.115, port 61616 and web console on port 8161
(actually I left as default and only changed brokerName="APP-004"). The
Slave node is installed on IP 10.198.14.57, port 61616 and web console port
8161. Changed a few things on activemq.xml of the Slave:

<broker ... brokerName="APP-008" destroyApplicationContextOnStop="true"
masterConnectorURI="tcp://10.198.14.115:61616"
shutdownOnMasterFailure="false">

First I start Master node and it works fine. All Java apps can post /
consume messages from different queues.

When I start Slave node I get no error or warn messages. But when I view the
queues in the web console, the "Number Of Pending Messages" always increase
and never decreases. "Messages Dequeued" and "Number of Consumers" are
always on ZERO. Tried to change Slave port to 62626 and nothing changed.

At first, my client apps are not using the failover connection URL
(java.naming.provider.url=failover://(tcp://ip-01:61616,tcp://ip-02:61616)?randomize=false).
The only point to master node, and I will change when I certify that cluster
is working fine. Even if I test this scenario on my workstation, it works
fine.

I am afraid if Master goes down, the messages will be processed again by the
Slave node. I could not reproduce this scenario in my workstation. Also this
does not seem to be right. Slave should increase "messages dequeued" as
master processes them, right???
       
Just to add more info. Start command is: nohup ./activemq start &

What can I do to see what is going on?

Should I look at any network configuration / restriction? 


--
View this message in context: http://activemq.2283324.n4.nabble.com/Slave-of-ActiveMQ-Cluster-does-not-dequeue-messages-tp3526475p3526475.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message