activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Liguori (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3287) Failover hangs during pubsub test and slave config
Date Tue, 19 Apr 2011 17:44:05 GMT
Failover hangs during pubsub test and slave config
--------------------------------------------------

                 Key: AMQ-3287
                 URL: https://issues.apache.org/jira/browse/AMQ-3287
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.4.2
         Environment: Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_23
Runtime = Java HotSpot(TM) Client VM 19.0-b09
            Reporter: Robert Liguori
            Priority: Minor
         Attachments: image.JPG

When I use the services element in my slave config (note that I do not use the auth attributes)
during a busy pubsub test, the failover hangs:

 <services>
    <masterConnector remoteURI= "tcp://192.168.10.99:61616" />
 </services>

Note that the master broker hangs when I perform a Ctrl-C.  This is the message that is seen:

INFO | The connection to '/192.168.10.95:7676' is taking a long time to shutdown.

A screenshot is attached.

Note: The broker does not hang on failover with the same config and *without* my test being
ran.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message