activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Liguori (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3259) Building with NetBeans 7.0 RC1 (w/ Maven 3.0.3) exposed malfored projects.
Date Sun, 03 Apr 2011 15:22:05 GMT
Building with NetBeans 7.0 RC1 (w/ Maven 3.0.3) exposed malfored projects.
--------------------------------------------------------------------------

                 Key: AMQ-3259
                 URL: https://issues.apache.org/jira/browse/AMQ-3259
             Project: ActiveMQ
          Issue Type: Improvement
    Affects Versions: 5.5.0
         Environment: Maven 3.0.3
Product Version = NetBeans IDE 7.0 RC1 (Build 201103280000)
Operating System = Windows Vista version 6.0 running on x86
Java; VM; Vendor = 1.6.0_23
Runtime = Java HotSpot(TM) Client VM 19.0-b09
            Reporter: Robert Liguori
            Priority: Minor


The following text was displayed during the build process with NetBeans 7.0 RC1:

"Some problems were encountered while building the effective model for org.apache.activemq:activemq-fileserver:war:5.5.0
The expression ${pom.groupId} is deprecated. Please use ${project.groupId} instead.
The expression ${pom.groupId} is deprecated. Please use ${project.groupId} instead.

Some problems were encountered while building the effective model for org.apache.activemq:activemq-web-demo:war:5.5.0
The expression ${pom.groupId} is deprecated. Please use ${project.groupId} instead.

Some problems were encountered while building the effective model for org.apache.activemq:activemq-xmpp:jar:5.5.0
'repositories.repository.layout' for maven-repository.dev.java.net uses the unsupported value
'legacy', artifact resolution might fail. @ line 42, column 15
'pluginRepositories.pluginRepository.layout' for maven-repository.dev.java.net uses the unsupported
value 'legacy', artifact resolution might fail. @ line 55, column 15

It is highly recommended to fix these problems because they threaten the stability of your
build.

For this reason, future Maven versions might no longer support building such malformed projects."

Can these minor issues be resolved?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message