activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Good (JIRA)" <>
Subject [jira] [Commented] (AMQ-3278) CRON scheduling does not work correctly
Date Fri, 08 Apr 2011 23:03:05 GMT


Matthew Good commented on AMQ-3278:

After restarting ActiveMQ, the messages that I couldn't see get delivered which probably is
why none show in the Queues list after the restart.
If I use Time To Wait and Number of Repeats instead of CRON, it works fine.

I don't know how to set up a unit test to test this given the need for a listener and such
a long delay.  I used the administration console to create the messages.  A very simple listener
will do.

> CRON scheduling does not work correctly
> ---------------------------------------
>                 Key: AMQ-3278
>                 URL:
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.5.0
>         Environment: Windows 7
>            Reporter: Matthew Good
> I have a listener with an event handler listening for messages and logging when they
come in.
> I sent a message to that queue with CRON string of "25 * * * *".  All other scheduler
properties are not set.  No ttl.
> The first time 25 after the hour comes around, a message is sent and my listener receives
> All subsequent times 25 after the hour come around, the listener doesn't receive anything.
> The admin console Queues page shows that the subsequent messages are waiting in the queue
but drilling into the queue shows no message.
> Restarting ActiveMQ and the Queues page doesn't show any messages.

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message