activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Kiorsak (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-1780) ActiveMQ broker does not automatically reconnect if the connection to the database is lost
Date Thu, 07 Apr 2011 03:56:05 GMT

    [ https://issues.apache.org/jira/browse/AMQ-1780?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13016673#comment-13016673
] 

Oleg Kiorsak commented on AMQ-1780:
-----------------------------------

Thanks Gary!

I think I "get it" now... adding that config tweak and also - very importantly - setting useDatabaseLock="false"
in jdbcPersistenceAdapter 

does the trick for a single standalone broker, but for a cluster there is still an outstanding
issue (where you mention all these too in comments): https://issues.apache.org/jira/browse/AMQ-2497

so yes if this issue (AMQ-1780) is meant to be the context of not-a-cluster setup only then
I can confirm it appears indeed to be fixed...

Hope the AMQ-2497 (as tricky as it sounds) does get fix in 5.6 as planned too... ;)














> ActiveMQ broker does not automatically reconnect if the connection to the database is
lost
> ------------------------------------------------------------------------------------------
>
>                 Key: AMQ-1780
>                 URL: https://issues.apache.org/jira/browse/AMQ-1780
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.0.0
>         Environment: Windows 2003 Server
>            Reporter: Jaya Srinivasan
>            Assignee: Gary Tully
>             Fix For: 5.5.0
>
>
> hi
> We are noticing that after any SQL Server restart or network blip between ActiveMQ and
the database, after the connection or the database comes back online activeMQ broker needs
to be restarted as well i.e it doesn't automatically re-establish connection to the database
as result any message send fails because the broker is still using the stale connection to
the database. 
> Is this designed behaviour or a bug? we are using ActiveMQ 5.0.0 and the latest version
of the JSQLConnect database driver: version 5.7. The database we are using is MS SQL Server
2005 
> Right now, in our production environment any time we have network maintenance or database
restart we also have to restart the ActiveMQ broker which is not a good option for us. 
> Also, We are using a single ActiveMQ broker and not the JDBC(Master/Slave) set up.
> Issue details in
> http://www.nabble.com/Database-connection-between-ActiveMQ-and-broker-td17321330s2354.html
> Please let me know if I need to give more information
> thanks
> jaya

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message