activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Liguori (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-3287) Failover hangs during pubsub test (slave config with services element)
Date Sat, 30 Apr 2011 14:45:03 GMT

     [ https://issues.apache.org/jira/browse/AMQ-3287?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Liguori updated AMQ-3287:
--------------------------------

    Description: 
While making use of the services and masterConnector elements in my slave config during a
pubsub test (where messages are being held), the failover delays after performing a Ctrl-C.

This is the message that is seen:

INFO | The connection to '/192.168.10.95:7676' is taking a long time to shutdown.

  was:
When I use the services element (shown below) in my slave config (note that I do not use the
auth attributes) during a busy pubsub test, the failover hangs after performing a Ctrl-C.

 <services>
    <masterConnector remoteURI= "tcp://192.168.10.99:61616" />
 </services>

This is the message that is seen:

INFO | The connection to '/192.168.10.95:7676' is taking a long time to shutdown.

A screenshot is attached.

Note: The broker does not hang on failover with the same config and *without* my test being
ran.

Also note that when I define the master in my broker element (shown below) and kill the broker
with Ctrl-C, everything works fine:

<broker xmlns="http://activemq.apache.org/schema/core" brokerName="testSlave" masterConnectorURI="tcp://192.168.10.95:61616"
dataDirectory="${activemq.base}/data" shutdownOnMasterFailure="false" deleteAllMessagesOnStartup="true">



> Failover hangs during pubsub test (slave config with services element)
> ----------------------------------------------------------------------
>
>                 Key: AMQ-3287
>                 URL: https://issues.apache.org/jira/browse/AMQ-3287
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.4.2
>         Environment: Operating System = Windows XP version 5.1 running on x86
> Java; VM; Vendor = 1.6.0_23
> Runtime = Java HotSpot(TM) Client VM 19.0-b09
>            Reporter: Robert Liguori
>            Priority: Minor
>         Attachments: image.JPG
>
>
> While making use of the services and masterConnector elements in my slave config during
a pubsub test (where messages are being held), the failover delays after performing a Ctrl-C.
> This is the message that is seen:
> INFO | The connection to '/192.168.10.95:7676' is taking a long time to shutdown.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message