activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From archana saini <archu...@gmail.com>
Subject Re: OnException is not being called properly
Date Tue, 26 Apr 2011 09:10:00 GMT
Hi,

I have now deployed my application on the same box where ActiveMQ is
installed. But its still not working in 3rd case.

I am not sure if it is a bug or i am doing something wrong. 

I am using simple code to connect to ActiveMQ and using onMessgae to get
messages and implementing ExcepionListener. However, its never call
onException in any case.

JNDI.properties:-
java.naming.factory.initial=org.apache.activemq.jndi.ActiveMQInitialContextFactory
java.naming.provider.url=failover:(tcp://host:61630)
connectionFactory=connectionFactory, queueConnectionFactory,
topicConnectionFactry
queue.destination=QueueName


Here are the cases i ran after deploying on same server:-

1. Stop ActiveMQ, it started retrying as per code logic. [Pass] 

2. Started application and it connected to ActiveMQ successfully. It
consumed messages also. Now stopped ActiveMQ, it works fine, it was trying
to reconnect and connected when ActiveMQ is UP [Pass] 
In logs, i can see message 
26 Apr 2011 04:56:29 WARN  FailoverTransport.java
-handleTransportFailure():226 - Transport
(rpc1044.daytonoh.ncr.com/192.127.152.44:61630) failed to tcp:/
/rpc1044.daytonoh.ncr.com:61630 , attempting to automatically reconnect due
to: java.io.EOFException
26 Apr 2011 04:57:40 INFO  FailoverTransport.java -doReconnect():878 -
Successfully reconnected to tcp://rpc1044.daytonoh.ncr.com:61630

3. Started application , it connected to ActiveMQ successfully. Now stopped
ActiveMQ, application stops immediately. [Fail] 
Only entry in logs:- 
26 Apr 2011 01:38:14 WARN  FailoverTransport.java
-handleTransportFailure():226 - Transport
(rpc1044.daytonoh.ncr.com/192.127.152.44:61630) failed to tcp:/
/rpc1044.daytonoh.ncr.com:61630 , attempting to automatically reconnect due
to: java.io.EOFException
And application stopped immediately, No Exception/error.

Now it should not be network issue as both applications and ActiveMQ are on
same server.

Please advise. Its now critical for my application as this behaviour is not
acceptable.

Thanks in advance!

Regards,
Archana

--
View this message in context: http://activemq.2283324.n4.nabble.com/OnException-is-not-being-called-properly-tp3454427p3475009.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message