activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mahmoud maalej (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-3239) Jboss blocked in startup when messages are in the que
Date Wed, 23 Mar 2011 13:11:05 GMT
Jboss blocked in startup when messages are in the que
-----------------------------------------------------

                 Key: AMQ-3239
                 URL: https://issues.apache.org/jira/browse/AMQ-3239
             Project: ActiveMQ
          Issue Type: Bug
          Components: Connector
    Affects Versions: 5.4.2
         Environment: - Jboss 5.1.0 GA
- Activemq 5.4.2
            Reporter: Mahmoud maalej


Reproducing senario:
1- Start activemq server
2- With admin console send a message to testqueue (message is enqueued)
3- Deploy activemq-ra.rar connector
4- deploy an ear containing (an mdb to consume the message)  and a simple application
5- start jboss

Always Jboss startup block after INFO  [ra.ActiveMQEndpointWorker] Successfully established
connection to broker [tcp://localhost:61616] and can't continue deployment of the ear which
contain the mdb consumer

Is there a specific config to do, to let activemq-ra.rar deployed without trying to send the
pending message untill the server starup and that the mdb beying ready to consume it. 

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message