activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Pieber (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-3142) Prepare the upgrade to Karaf 2.2
Date Thu, 03 Mar 2011 07:48:37 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3142?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13001901#comment-13001901
] 

Andreas Pieber commented on AMQ-3142:
-------------------------------------

I've patched AMQ to run smoothly on karaf-2.2.0. @Dan: Feel free to give the patch attached
to this issue a try and report your feedback

> Prepare the upgrade to Karaf 2.2
> --------------------------------
>
>                 Key: AMQ-3142
>                 URL: https://issues.apache.org/jira/browse/AMQ-3142
>             Project: ActiveMQ
>          Issue Type: Bug
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 5.5.0, 6.0.0
>
>         Attachments: AMQ3142.patch
>
>
> ActiveMQ 5.4.x uses Karaf 2.1.0.
> Karaf 2.2.0 will be released soon. A change affects ActiveMQ: a new Felix gogo version.
> For instance, if you try to deploy ActiveMQ 5.4.2 on Karaf 2.1.99-SNAPSHOT, you will
get an unresolved constraint as the Felix Gogo export package changed.
> In preparation for the support of Karaf 2.2.0, I'm gonna submit a patch to update the
Import-Package and use the corresponding Gogo version.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message