activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiram Chirino <hi...@hiramchirino.com>
Subject Re: Apollo & SSL problems
Date Mon, 10 Jan 2011 13:49:22 GMT
Been reviewing the code again, and I still don't spot anything
obvious.  Any chance I can get access to the systems were your able to
reproduce this on?  Perhaps with a couple of extra debugging
statements on a few test runs I can figure out whats going on.

Regards,
Hiram

FuseSource
Web: http://fusesource.com/




On Mon, Jan 10, 2011 at 4:33 AM, Lionel Cons <lionel.cons@cern.ch> wrote:
> Hiram Chirino writes:
>  > Ok just tried across hosts and still get the same results.  You sure
>  > you running against a recent build?  I know there was a bug similar to
>  > that a little while back.
>
> Hiram,
>
> Here is what my colleague (in CC) found:
>
>  | I think the source code which needs attention is:
>  |
>  | http://svn.apache.org/viewvc/activemq/activemq-apollo/trunk/apollo-tcp/src/main/java/org/apache/activemq/apollo/transport/tcp/SslTransport.java
>  |
>  | That is in the server's code so probably the apollo developers you are
>  | in contact with will be able to look at it directly. I believe the
>  | problem is when the server is sending data as a part of the SSL
>  | handshake and not all of the data is sent to the channel during a call
>  | of secure_write() (via that method's call to flush()). I expect the
>  | apollo developer will be able to follow up on it; if they have any
>  | queries about what I checked you can put them in contact with me.
>
> I hope this helps. Feel free to contact David for more information.
>
> Cheers,
>
> Lionel
>

Mime
View raw message