activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] Created: (AMQ-3142) Prepare the upgrade to Karaf 2.2
Date Mon, 17 Jan 2011 09:13:43 GMT
Prepare the upgrade to Karaf 2.2
--------------------------------

                 Key: AMQ-3142
                 URL: https://issues.apache.org/jira/browse/AMQ-3142
             Project: ActiveMQ
          Issue Type: Bug
            Reporter: Jean-Baptiste Onofré
             Fix For: 5.5.0, 6.0.0


ActiveMQ 5.4.x uses Karaf 2.1.0.

Karaf 2.2.0 will be released soon. A change affects ActiveMQ: a new Felix gogo version.

For instance, if you try to deploy ActiveMQ 5.4.2 on Karaf 2.1.99-SNAPSHOT, you will get an
unresolved constraint as the Felix Gogo export package changed.

In preparation for the support of Karaf 2.2.0, I'm gonna submit a patch to update the Import-Package
and use the corresponding Gogo version.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message