activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "andreas.meinecke" <andreas.meine...@ovgu.de>
Subject Re: Building ActiveMQCpp 3.2.4 on Windows 7 x64
Date Fri, 21 Jan 2011 14:40:02 GMT

Am 21.01.2011 15:25, schrieb Timothy Bish [via ActiveMQ]:
> On Fri, 2011-01-21 at 06:18 -0800, andreas.meinecke wrote:
>
> > Hey all,
> >
> > i am trying to build the ActiveMQCpp libraries for windows x64 with 
> vs2008.
> >
> > When i build it in debug mode x64, everything went fine until i try 
> to link
> > the libactivemq-cppd.lib from an other project. Here i get about 600
> > unresolved external symbol errors in libactivemq-cppd.lib.
> >
> > So i tried to build the DebugDLL configuration, but here i get about 
> 1500
> > unresolved external symbol errors during linking.
> >
> > Any hints?
> >
> > best regards,
> > Andreas
>
> Best thing to do is look at the settings in the example project to see
> how that is configured, you need to be linking in the apr and apr-util
> libs plus openssl if you enabled SSL.
>
> Regards
Hello Tim,

many thanks for your very fast answer. I have compiled apr and apr-util
as well for windows x64 and yes, both libs are linked into the project.
But this is not solving my unresolved external symbol errors.

Any other ideas?

best regards,
Andreas

-- 
Dipl.-Ing.
Andreas Meinecke

Otto-von-Guericke-Universität Magdeburg
SFB/Transregio 62
G03-202
Universitätsplatz 2
39106 Magdeburg

Telefon: 0391 67-12415 (18887)
www.ovgu.de


-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Building-ActiveMQCpp-3-2-4-on-Windows-7-x64-tp3229732p3229788.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message