activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Norman Maurer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-3164) Upgrade the bundled service wrapper to version 3.5.7 to remove 4GB heap limitation
Date Wed, 26 Jan 2011 19:06:44 GMT

    [ https://issues.apache.org/jira/browse/AMQ-3164?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12987167#action_12987167
] 

Norman Maurer commented on AMQ-3164:
------------------------------------

The problem is the new versions of service wrapper are shipped with gpl2 license. So its not
possible to include a newer version. 

See also:

http://www.mail-archive.com/dev@maven.apache.org/msg74005.html

> Upgrade the bundled service wrapper to version 3.5.7 to remove 4GB heap limitation
> ----------------------------------------------------------------------------------
>
>                 Key: AMQ-3164
>                 URL: https://issues.apache.org/jira/browse/AMQ-3164
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Broker
>    Affects Versions: 5.4.2
>            Reporter: Craig Condit
>            Priority: Minor
>
> The bundled service wrapper (3.2.3) library does not allow setting of heap > 4 GB,
even on 64-bit machines. According to the service-wrapper changelogs, this limitation was
lifted in 3.3.0. The current stable release is 3.5.7.
> Ideally the newest stable release would be used, but if that causes compatibility issues,
moving to at least 3.3.0 would resolve the immediate issue.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message