activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Gellings (JIRA)" <jira+amq...@apache.org>
Subject [jira] Commented: (AMQNET-294) durable subscription message loss when master broker fails to slave
Date Thu, 16 Dec 2010 03:55:01 GMT

    [ https://issues.apache.org/jira/browse/AMQNET-294?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12971956#action_12971956
] 

Mark Gellings commented on AMQNET-294:
--------------------------------------

I tested this on a Windows XP SP3 machine at home.  So not on our company domain in order
to rule out my Windows 7 macihne at work.   With a canned ActiveMQ 5.4.2 broker and your test
with automated failover running on this XP machine, I get the same result, gets to 50 messages
and then stops processing.

One thing to note is I was not running pure master/slave, so for my failover URI the tcp addresses
were the same, both localhost:61616.  But I don't think that would make a difference at all.

If you could look at the log files I provided Tim maybe you'll see why this isn't working
for me.  I don't understand why both the java and .net consumers stop processing messages
for me but not for you.

Thanks!

> durable subscription message loss when master broker fails to slave
> -------------------------------------------------------------------
>
>                 Key: AMQNET-294
>                 URL: https://issues.apache.org/jira/browse/AMQNET-294
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: NMS
>    Affects Versions: 1.4.1
>         Environment: Windows 7 (client), Windows Server 2008 64-bit (server brokers run
on), Sql Server 2008 (database)
>            Reporter: Mark Gellings
>            Assignee: Jim Gomes
>             Fix For: 1.5.0
>
>         Attachments: Apache.NMS.Test (2).zip, Apache.NMS.Test.zip, DurableConsumerTest.cs,
DurableSubscriberFailoverTest.java, NMSLog.txt, NMSLogLocalFreshCannedActiveMQ542Broker.txt,
TimsTestRevisedSlightly.zip
>
>
> We are seeing message loss on a durable subscription when using NMS ActiveMQ v1.4.1 and
ActiveMQ v5.4.1.
> Please run the included NUnit test and watch the console output.  When it says "Failover
the broker now!" do as it says.  About 75% of the time less than half of the expected 250
messages come through.
> Using version 1.1 of NMS the majority of the time the test passes.  I have seen it fail
only a few times with this earlier version, and when it does there are only a couple messages
that don't come through.
> In the zip file will be the unit test, and a config directory containing the master and
slave activemq configurations.  We are using JDBC master/slave.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message