activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQCPP-332) First send after we restart broker seems to always get a CmsException
Date Tue, 23 Nov 2010 15:27:25 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-332?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=63469#action_63469
] 

Timothy Bish commented on AMQCPP-332:
-------------------------------------

This is really related to the bug found in AMQCPP-316.  The CMSTemplate doesn't detect that
the connection was dropped and so it remains partially active allowing the InactivityMonitor
to eventually detect that the connection is gone, but since there's no exception listener
registered with a CMSTemplate instance the only time this will be shown is the next time a
send call occurs and the InactivityMonitor throws the exception back to inform the caller
that its failed.  The next call then should succeed as the CMSTemplate code would reconnect
now that its detected that its connection has failed.

> First send after we restart broker seems to always get a CmsException
> ---------------------------------------------------------------------
>
>                 Key: AMQCPP-332
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-332
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: CMS Impl
>    Affects Versions: 3.2.3
>         Environment:  Windows xp service pack 3, ActiveMQ broker 5.3.1, apr 1.4.2, apr-util
1.3.9, apr iconv 1.2.1
>            Reporter: Helen Huang
>            Assignee: Timothy Bish
>             Fix For: 3.2.4
>
>         Attachments: BrokerMonitor2.zip
>
>
> First send after we restart broker seems to always get a CmsException.
> Steps to recreate the problem:
> (1) download and unzip the attached test program: BrokerMonitor2.zip. This program is
very similar to the test program for jira item 328 with just a few modifications. (https://issues.apache.org/activemq/browse/AMQCPP-328)
> (2) Start broker
> (3) Run the test program. The test program will iterate for 10000 times. In each iteration,
it will first send out a message, and then prompt you to enter a char to continue. Please
do that and make sure that the first a few messages are sent without any problems.
> (4) Restart broker. Wait for a while,  Maybe 2-5 mins.
> (5) Enter a char for the test program to continue. Observe that the next send message
gets a CmsException with the message "Channel was inactive for too long"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message