activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Petri Riipinen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-2999) peer transport factory mapping localhost incorrectly to loopback
Date Wed, 27 Oct 2010 06:49:01 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-2999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=62860#action_62860
] 

Petri Riipinen commented on AMQ-2999:
-------------------------------------

Tested on 27/Oct/10 by original reporter and works now.

> peer transport factory mapping localhost incorrectly to loopback
> ----------------------------------------------------------------
>
>                 Key: AMQ-2999
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2999
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.3.2, 5.4.0, 5.4.1
>         Environment: Windows XP 32-bit, SUN JDK 1.6 update 21
>            Reporter: Petri Riipinen
>            Assignee: Gary Tully
>             Fix For: 5.5.0
>
>
> Issue described in the first posting of that thread: http://activemq.2283324.n4.nabble.com/Problem-with-simple-peer-configuration-my-config-or-AMQ-issue-td3013268.html#a3013268
> Reply from Gary Tully explains the problem: "That looks like a bug in the peer transport
factory. I uses localhost:0 as the tcp transport url, but localhost maps to the 
> loopback address since 5.3[1] so the connection is refused. The peer transport factory
should use the wildcard address, 0.0.0.0"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message