activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "heriyanto binduni (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-3009) using ajax client with jquery adapter, activemq not automatically start broadcast data, need refresh first
Date Sun, 31 Oct 2010 14:40:00 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-3009?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

heriyanto binduni updated AMQ-3009:
-----------------------------------

    Description: 
i'm using jquery adapter as describe here: https://issues.apache.org/activemq/browse/AMQ-1377
to listening message via browser but activemq session seem not start broadcast data to webpage
as soon as we open the page. need to refresh the page first before activemq starting to broadcast
message. the same problem not happen if i use the old ways, using prototype and behaviour
script. have not try it with prototype adapter. 

from firebugs i see it send request to server something like this: http://localhost:8081/demo/amq?timeout=2000&d=1288535246706&r=0.7241340907954991,
but still no broadcast data until page refresh. any solution for this?

using the old protype and behaviour script would lead to another bugs, prototype conflict
with jquery as reported on this: https://issues.apache.org/activemq/browse/AMQ-2427

tq

  was:
i'm using jquery adapter to listening message via browser but activemq session seem not start
as soon as we open the page. need to refresh the page first before activemq starting to broadcast
message. the same problem not happen if i use the old ways, using prototype and behaviour.
have not try it with prototype adapter. 

from firebugs i see it send request to server something like this: http://localhost:8081/demo/amq?timeout=2000&d=1288535246706&r=0.7241340907954991,
but still no broadcast data until page refresh. any solution for this?

using the old protype and behaviour script would lead to another bugs, prototype conflict
with jquery as reported on this: https://issues.apache.org/activemq/browse/AMQ-2427

tq


> using ajax client with jquery adapter, activemq not automatically start broadcast data,
need refresh first
> ----------------------------------------------------------------------------------------------------------
>
>                 Key: AMQ-3009
>                 URL: https://issues.apache.org/activemq/browse/AMQ-3009
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: JMS client
>    Affects Versions: 5.4.1
>         Environment: windows 7, windows server 2008, jquery 1.4.3, firefox 3.6.12
>            Reporter: heriyanto binduni
>
> i'm using jquery adapter as describe here: https://issues.apache.org/activemq/browse/AMQ-1377
> to listening message via browser but activemq session seem not start broadcast data to
webpage as soon as we open the page. need to refresh the page first before activemq starting
to broadcast message. the same problem not happen if i use the old ways, using prototype and
behaviour script. have not try it with prototype adapter. 
> from firebugs i see it send request to server something like this: http://localhost:8081/demo/amq?timeout=2000&d=1288535246706&r=0.7241340907954991,
but still no broadcast data until page refresh. any solution for this?
> using the old protype and behaviour script would lead to another bugs, prototype conflict
with jquery as reported on this: https://issues.apache.org/activemq/browse/AMQ-2427
> tq

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message