activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-2894) Configuration error using '&' in transportConnector configuration
Date Thu, 02 Sep 2010 12:09:41 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary Tully updated AMQ-2894:
----------------------------

    Description: 
Using '&' in properties concatenation in broker configuration urls, brings to the following
error:

12:25:49,890 WARN  [ActiveMQResourceAdapter] Could not start up embeded ActiveMQ Broker 'xbean:file://C:/broker-config.xml':
Line 85 in XML
document from URL [file://C:/broker-config.xml] is invalid; nested exception is org.xml.sax.SAXParseException:
The reference to entity "transport.initialDelayTime" must end with the ';' delimiter.

{code}...
    <transportConnectors>
      <transportConnector brokerName="localhost" uri="nio://0.0.0.0:61616" />
      <transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&transport.initialDelayTime=4000"
/>
    </transportConnectors>
...{code}

But using:

{code}
<transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&amp;transport.initialDelayTime=4000"
/>{code}

the broker starts correctly.

XML schema should be reviewed.

  was:
Using '&' in properties concatenation in broker configuration urls, brings to the following
error:

12:25:49,890 WARN  [ActiveMQResourceAdapter] Could not start up embeded ActiveMQ Broker 'xbean:file://C:/broker-config.xml':
Line 85 in XML
document from URL [file://C:/broker-config.xml] is invalid; nested exception is org.xml.sax.SAXParseException:
The reference to entity "transport.initialDelayTime" must end with the ';' delimiter.

...
    <transportConnectors>
      <transportConnector brokerName="localhost" uri="nio://0.0.0.0:61616" />
      <transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&transport.initialDelayTime=4000"
/>
    </transportConnectors>
...

But using:

<transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&amp;transport.initialDelayTime=4000"
/>

the broker starts correctly.

XML schema should be reviewed.


use code so {code}&amp;{code} is not replaced by render.

> Configuration error using '&' in transportConnector configuration 
> ------------------------------------------------------------------
>
>                 Key: AMQ-2894
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2894
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.4.1
>            Reporter: Colombo Marco
>             Fix For: 5.4.1
>
>
> Using '&' in properties concatenation in broker configuration urls, brings to the
following error:
> 12:25:49,890 WARN  [ActiveMQResourceAdapter] Could not start up embeded ActiveMQ Broker
'xbean:file://C:/broker-config.xml': Line 85 in XML
> document from URL [file://C:/broker-config.xml] is invalid; nested exception is org.xml.sax.SAXParseException:
The reference to entity "transport.initialDelayTime" must end with the ';' delimiter.
> {code}...
>     <transportConnectors>
>       <transportConnector brokerName="localhost" uri="nio://0.0.0.0:61616" />
>       <transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&transport.initialDelayTime=4000"
/>
>     </transportConnectors>
> ...{code}
> But using:
> {code}
> <transportConnector brokerName="localhost" name="http" uri="http://0.0.0.0:61617?transport.readCheckTime=4000&amp;transport.initialDelayTime=4000"
/>{code}
> the broker starts correctly.
> XML schema should be reviewed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message