activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mats Henrikson (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-2928) new 5.4.0 activemq sysv init script tries to open the JDWP debug port when run with "stop"
Date Tue, 21 Sep 2010 04:02:40 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2928?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mats Henrikson updated AMQ-2928:
--------------------------------

    Description: 
With the new ActiveMQ 5.4.0 if you have /etc/default/activemq configured with the following
line:

{noformat}
# Uncomment to enable remote debugging
ACTIVEMQ_DEBUG_OPTS="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005"
{noformat}

Then when you try to shut down a running ActiveMQ broker instance using the init script with
the "stop" command, the Java process that attempts to shut it down also tries and fails to
open the same JDWP port:

{noformat}
root@sts-chc-matsh:/# ls -l /etc/init.d/activemq
lrwxrwxrwx 1 root root 32 2010-09-16 13:10 /etc/init.d/activemq -> /usr/local/apache-activemq-5.4.0/bin/activemq*

root@sts-chc-matsh:/# /etc/init.d/activemq stop
INFO: Loading '/etc/default/activemq'
INFO: Using java '/usr/lib/jvm/java-6-sun/bin/java'
INFO: changing to user 'activemq' to invoke java
INFO: Waiting at least 30 seconds for regular process termination of pid '6764' : ERROR: transport
error 202: bind failed: Address already in use
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
..............................
INFO: Regular shutdown not successful,  sending SIGKILL to process with pid '6764'
{noformat}

  was:
With the new ActiveMQ 5.4.0 if you have /etc/default/activemq configured with the following
line:

{panel}
# Uncomment to enable remote debugging
ACTIVEMQ_DEBUG_OPTS="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005"
{panel}

Then when you try to shut down a running ActiveMQ broker instance using the init script with
the "stop" command, the Java process that attempts to shut it down also tries and fails to
open the same JDWP port:

{noformat}
root@sts-chc-matsh:/# ls -l /etc/init.d/activemq
lrwxrwxrwx 1 root root 32 2010-09-16 13:10 /etc/init.d/activemq -> /usr/local/apache-activemq-5.4.0/bin/activemq*

root@sts-chc-matsh:/# /etc/init.d/activemq stop
INFO: Loading '/etc/default/activemq'
INFO: Using java '/usr/lib/jvm/java-6-sun/bin/java'
INFO: changing to user 'activemq' to invoke java
INFO: Waiting at least 30 seconds for regular process termination of pid '6764' : ERROR: transport
error 202: bind failed: Address already in use
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
..............................
INFO: Regular shutdown not successful,  sending SIGKILL to process with pid '6764'
{noformat}


> new 5.4.0 activemq sysv init script tries to open the JDWP debug port when run with "stop"
> ------------------------------------------------------------------------------------------
>
>                 Key: AMQ-2928
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2928
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.4.0
>            Reporter: Mats Henrikson
>            Priority: Minor
>
> With the new ActiveMQ 5.4.0 if you have /etc/default/activemq configured with the following
line:
> {noformat}
> # Uncomment to enable remote debugging
> ACTIVEMQ_DEBUG_OPTS="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005"
> {noformat}
> Then when you try to shut down a running ActiveMQ broker instance using the init script
with the "stop" command, the Java process that attempts to shut it down also tries and fails
to open the same JDWP port:
> {noformat}
> root@sts-chc-matsh:/# ls -l /etc/init.d/activemq
> lrwxrwxrwx 1 root root 32 2010-09-16 13:10 /etc/init.d/activemq -> /usr/local/apache-activemq-5.4.0/bin/activemq*
> root@sts-chc-matsh:/# /etc/init.d/activemq stop
> INFO: Loading '/etc/default/activemq'
> INFO: Using java '/usr/lib/jvm/java-6-sun/bin/java'
> INFO: changing to user 'activemq' to invoke java
> INFO: Waiting at least 30 seconds for regular process termination of pid '6764' : ERROR:
transport error 202: bind failed: Address already in use
> ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
> JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
> FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
> ..............................
> INFO: Regular shutdown not successful,  sending SIGKILL to process with pid '6764'
> {noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message