activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-2011) activemq-jpa-store is incompatible with postgresql - offset is a reserved word
Date Sat, 18 Sep 2010 16:47:53 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2011?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bruce Snyder updated AMQ-2011:
------------------------------

    Fix Version/s: 5.5.0
                       (was: 5.4.1)

> activemq-jpa-store is incompatible with postgresql - offset is a reserved word
> ------------------------------------------------------------------------------
>
>                 Key: AMQ-2011
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2011
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>            Reporter: Fredrik Jonson
>            Priority: Minor
>             Fix For: 5.5.0
>
>         Attachments: rename-offset-dataoffset-patch.txt
>
>
> The word "offset" is reserved in postgresql and cannot be used for column names. Activemq:s
JPA store has a property named offset in the entity bean StoredMessageReference. The supplied
patch (from trunk) renames the property from offset to dataOffset, which eliminates the postgresql
incompatibility.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message