activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] Updated: (AMQ-2938) ActiveMQ Console requires Jasypt bundle which is not part of the ActiveMQ features
Date Fri, 24 Sep 2010 06:50:40 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2938?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated AMQ-2938:
--------------------------------------

    Attachment: AMQ-2938-trunk.patch

Patch on trunk.

> ActiveMQ Console requires Jasypt bundle which is not part of the ActiveMQ features
> ----------------------------------------------------------------------------------
>
>                 Key: AMQ-2938
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2938
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.4.1
>            Reporter: Jean-Baptiste Onofré
>         Attachments: AMQ-2938-trunk.patch
>
>
> ActiveMQ Console OSGi bundle now requires org.jasypt.encryption.pbe package (defined
in import package statement).
> Unfortunately the ActiveMQ feature doesn't provide the jasypt bundle.
> So, when you install and start ActiveMQ feature, you get:
> java.lang.Exception: Could not start bundle mvn:org.apache.activemq/activemq-console/5.4.1
in feature(s) : Unresolved constraint in bundle org.apache.activemq.activemq-console [44]:
Unable to resolve 44.0: missing requirement [44.0] package; (
> package=org.jasypt.encryption.pbe) - [44.0] package; (package=org.jasypt.encryption.pbe)
> I'm gonna submit a patch to provide a clean ActiveMQ feature.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message