activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dejan Bosanac (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-2813) BrokerService @PostConstruct invalidates XBeanBrokerService w/ start=false
Date Mon, 06 Sep 2010 09:39:41 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2813?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dejan Bosanac resolved AMQ-2813.
--------------------------------

    Fix Version/s: 5.4.1
                       (was: 5.4.0)
       Resolution: Fixed

Patch applied with svn revision 992984. Thanks Dan.

The problem this missed in our tests was, because XBean+Spring combination doesn't call @PostConstruct
on parent objects as it is done in EJB environment you're using.

> BrokerService @PostConstruct invalidates XBeanBrokerService w/ start=false
> --------------------------------------------------------------------------
>
>                 Key: AMQ-2813
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2813
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.3.1
>            Reporter: Dan Nawrocki
>            Assignee: Dejan Bosanac
>            Priority: Minor
>             Fix For: 5.4.1
>
>         Attachments: broker_startup_fix.patch
>
>
> - XBeanBrokerService#afterPropertiesSet() method checks the start flag and is annotated
as @PostConstruct so it's called at startup
> - BrokerService#start() method has the @PostConstruct annotation as well
> - There is no way for the BrokerService class to check the 'start' flag in the XBeanBrokerService
subclass.
> - Spring will call BOTH @PostConstruct methods resulting in the broker being started
regardless of the xbean start flag
> According to Gary Tully:
> That looks like a bug that was introduced in
> http://svn.apache.org/viewvc?rev=908182&view=rev the postConstruct on
> the start method does invalidate the
> XBeanBrokerService#afterPropertiesSet()  smarts. 
> As discussed in:
> http://old.nabble.com/XBean-%27start%3Dfalse%27-not-working--td29086727.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message