activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Alexander Schäfer (JIRA) <j...@apache.org>
Subject [jira] Updated: (AMQ-2901) Repeating error of client on reconnect
Date Tue, 07 Sep 2010 10:59:40 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2901?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dirk Alexander Schäfer updated AMQ-2901:
----------------------------------------

    Component/s: Broker
                 JMS client

> Repeating error of client on reconnect
> --------------------------------------
>
>                 Key: AMQ-2901
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2901
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker, JMS client
>    Affects Versions: 5.4.0
>         Environment: redhat linux; java 1.6
>            Reporter: Dirk Alexander Schäfer
>
> recently we upgraded our activeMq instanzes from 5.3.1 to 5.4.0. we also upgraded the
client API used in our mule-based services. since that upgrade we are facing with strange
reconnet errors. we have a network of brokers with two instances. they are located behinde
a hardware loadbalancer over which our clients connect to the brokers. if we restart one of
the brokers, the clients connected to it perform a reconnect and are getting linked to the
other broker. in our services we use a lot of queues and topics.
> it seems that some topics are unable to reconnect randomly. on one of our client machines
the reconnect to a durable topic wasn't possible anymore (Root Exception was: Durable consumer
is in use for client: myUniqueConnectorName and subscriptionName: myDurableSubscriberName(JMS
Code: null). Type: class javax.jms.JMSException ). on the other machine a reconnect to another,
non-durable topic (Root Exception was: Channel was inactive for too long: /w.x.y.z:61616.
Type: class org.apache.activemq.transport.InactivityIOException ). they did not reconnect
at all until the services were restarted.
> we were not having this problems with the version 5.3.1.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message