activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Helen Huang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQCPP-315) Advisory messages do not work with multiple listeners
Date Mon, 30 Aug 2010 15:45:41 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=61523#action_61523
] 

Helen Huang commented on AMQCPP-315:
------------------------------------

My operating system is Windows XP Professional, version 2002, service pack 3

The connection IDs  for AdvisoryMessageListener seem to be always 0:0 and 0:1.  When we start
up the second instance of AdvisoryMessageListener ,  activemqcpp removes the connections that
has been created for the first instance ( because they use same ids?). The test has been done
using activemqcpp lib version 3.2.2. Will test with 3.2.x and see if any of the latest fix
has resolved the problem.

> Advisory messages do not work with multiple listeners
> -----------------------------------------------------
>
>                 Key: AMQCPP-315
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-315
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>    Affects Versions: 3.2.2
>         Environment: Windows, ActiveMQ 5.3.1
>            Reporter: Helen Huang
>            Assignee: Timothy Bish
>         Attachments: AdvisoryMessageListener2.zip, vs2005-build.zip
>
>
> We found that the advisory messages do not work as expected when there are multiple consumers
listening to the same advisory topics.
> We have three applications, AdvisoryMessageListener, MessageListener, and MessageSender.
> AdvisoryMessageListener listens to the following two topics:
> ActiveMQ.Advisory.Consumer.Topic.cpp.itemLookup
> ActiveMQ.Advisory.Producer.Topic.cpp.itemLookup
> MessageListener listens to topic: cpp.itemLookup
> MessageSender sends messages to topic: cpp.itemLookup
> If there is only one instance of AdvisoryMessageListener , then everything work fine.
We can get the advisory messages when we start/shut down MessageListener or MessageSender
. However, when we start a second instance of AdvisoryMessageListener , it seems to knock
out the existing connection of the first  AdvisoryMessageListener. The first instance can
no longer receive any advisory messages after that. 
> This problem could be related to the problem reported in jira item "AMQCPP-314 Starting
app with Com using cms destroys connection of other app. New problem with recent lib version".
However in our problem,  we do not have any COM layers.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message