activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Gomes (JIRA)" <jira+amq...@apache.org>
Subject [jira] Resolved: (AMQNET-274) Failover Transport URI parameters should be prefixed with "transport."
Date Fri, 20 Aug 2010 23:37:47 GMT

     [ https://issues.apache.org/activemq/browse/AMQNET-274?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jim Gomes resolved AMQNET-274.
------------------------------

    Resolution: Fixed

> Failover Transport URI parameters should be prefixed with "transport."
> ----------------------------------------------------------------------
>
>                 Key: AMQNET-274
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-274
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ
>    Affects Versions: 1.3.0
>            Reporter: Jim Gomes
>            Assignee: Jim Gomes
>             Fix For: 1.4.0
>
>   Original Estimate: 30 minutes
>  Remaining Estimate: 30 minutes
>
> The parsing of transport-specific properties is standardized to have the prefix of "transport.".
 However, the failover transport factory does not parse them correctly.
> Examples:
> The following works --
> {{activemq:tcp://localhost:61616?transport.RequestTimeout=1000}}
> but it will fail if the URI is switched to use the failover transport --
> {{activemq:failover:tcp://localhost:61616?transport.RequestTimeout=1000}}
> Current implementation requires the removal of the "transport." prefix, which is incorrect
--
> {{activemq:failover:tcp://localhost:61616?RequestTimeout=1000}}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message