activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stan Lewis (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-2764) For "duplex" network connection, after restart one ActiveMQ, message is missing.
Date Mon, 23 Aug 2010 20:49:47 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2764?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stan Lewis updated AMQ-2764:
----------------------------

    Attachment: test-case.txt

I've put together a test case similar to the NetworkReconnectTest that specifically goes through
the steps in Lowry's description but I can't seem to reproduce this on trunk.  Have you tried
this on the 5.4 release or on the latest snapshot?

> For "duplex" network connection,  after restart one ActiveMQ,  message is missing.
> ----------------------------------------------------------------------------------
>
>                 Key: AMQ-2764
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2764
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.3.1
>         Environment: Windows2k3,  AMQ 5.3.1, 
>            Reporter: Qingyi Gu
>             Fix For: 5.4.1
>
>         Attachments: Remote-Console1.JPG, Remote-Console2.JPG, Remote-Console3.JPG, SCA-consumer1.JPG,
test-case.txt
>
>
> I have two AMQ setup.  And they use duplex network connection between.   After I restart
one ActiveMQ which initiates the connection,  half of the message are missing.    In order
to avoid this problem,  I have restart the other ActiveMQ.   And this only happens when I
use "staticallyIncludedDestinations" config in broker.
> 1 SETUP:
> a) SCA server has a network connector to remote server114.  In order to repeat this problem,
you have to use "staticallyIncludedDestinations".
> <networkConnector name="SCA" uri="static://(https://192.168.3.114:61617)" duplex="true">
>                <staticallyIncludedDestinations>
>                               <queue physicalName="R"/>
>                </staticallyIncludedDestinations>
> </networkConnector>
> b) SCA server has a java code consumer listening on queue R:
> c)  Remote server114 is listening on 61617, see config below;
> <transportConnectors> 
>            <transportConnector name="openwire" uri="tcp://0.0.0.0:61616"/> 
>            <transportConnector name="https" uri="https://0.0.0.0:61617?needClientAuth=true"/>

> </transportConnectors> 
> (See attached picture "Remote-Console1.jpg".)
> 2. Restart activemq on SCA server and restart consumer application listening on queue
R on SCA too.  Remote server114 activemq admin console shows there are two consumers on R.

> (See attached picture "Remote-Console2.jpg")
> 3 Start a producer on remote server114 to send 10 messages to R.  On SCA server, consumer
on R  only receives 5 messages.
> (See attached picture "SCA-consumer1.JPG")
> 4. On remote server114 activemq admin console, these 10 messages are divided by these
two consumers.
> (See attached picture "Remote-Console3.jpg")

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message