activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <jira+amq...@apache.org>
Subject [jira] Commented: (AMQNET-263) Upgrade to NUnit 2.5.5
Date Mon, 19 Jul 2010 18:15:52 GMT

    [ https://issues.apache.org/activemq/browse/AMQNET-263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=60763#action_60763
] 

Timothy Bish commented on AMQNET-263:
-------------------------------------

This is what I see when I run the nant test target on my Windows XP 32bit VM instance.

{noformat}
set-net-2.0-framework-configuration:

 [property] Target framework changed to "Microsoft .NET Framework 2.0".
     [echo] Doing a signed debug build for the .NET 2.0 framework

dependency-init:

     [exec] NUnit version 2.5.5.10112
     [exec] Copyright (C) 2002-2009 Charlie Poole.
     [exec] Copyright (C) 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov.
     [exec] Copyright (C) 2000-2002 Philip Craig.
     [exec] All Rights Reserved.
     [exec]
     [exec] Runtime Environment -
     [exec]    OS Version: Microsoft Windows NT 5.1.2600 Service Pack 3
     [exec]   CLR Version: 2.0.50727.3607 ( Net 2.0 )
     [exec]
     [exec] ProcessModel: Default    DomainUsage: Default

{noformat}

Bunch of tests......then

{noformat}
     [exec]
     [exec] Tests run: 445, Errors: 198, Failures: 2, Inconclusive: 0, Time: 99.342848 seconds
     [exec]   Not run: 0, Invalid: 0, Ignored: 0, Skipped: 0
     [exec]
     [exec] Errors and Failures:
     [exec] 1) TearDown Error : Apache.NMS.ActiveMQ.Test.AMQQueueTransactionTest.AMQTransactionTestSupport.TestCloseConsumerBeforeCommit
     [exec]    System.UriFormatException : Invalid URI: The URI scheme is not valid.
     [exec] TearDown : System.NullReferenceException : Object reference not set to an instance
of an object.
     [exec]    at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
     [exec]    at System.Uri..ctor(String uriString)
     [exec]    at Apache.NMS.Util.URISupport.ParseComposite(Uri uri, CompositeData rc, String
ssp) in c:\dev\NMS\src\main\csharp\Util\URISupport.
cs:line 463
     [exec]    at Apache.NMS.Util.URISupport.ParseComposite(Uri uri) in c:\dev\NMS\src\main\csharp\Util\URISupport.cs:line
415
     [exec]    at Apache.NMS.ActiveMQ.Connection.CreateSession(AcknowledgementMode sessionAcknowledgementMode)
in c:\dev\NMS.ActiveMQ\src\main\cs
harp\Connection.cs:line 408
     [exec]    at Apache.NMS.ActiveMQ.Test.AMQTransactionTestSupport.ReconnectSession() in
c:\dev\NMS.ActiveMQ\src\test\csharp\AMQTransactionTest
Support.cs:line 493
     [exec]    at Apache.NMS.ActiveMQ.Test.AMQTransactionTestSupport.Reconnect() in c:\dev\NMS.ActiveMQ\src\test\csharp\AMQTransactionTestSupport
.cs:line 482
     [exec]    at Apache.NMS.ActiveMQ.Test.AMQTransactionTestSupport.SetUp() in c:\dev\NMS.ActiveMQ\src\test\csharp\AMQTransactionTestSupport.cs:
line 54
     [exec] --TearDown
     [exec]    at Apache.NMS.ActiveMQ.Test.AMQTransactionTestSupport.TearDown() in c:\dev\NMS.ActiveMQ\src\test\csharp\AMQTransactionTestSupport.
cs:line 60
{noformat}

This was working until the switch to 2.5.5 so not sure what's going on now, errors are about
the same under Mono on Linux as well.


> Upgrade to NUnit 2.5.5
> ----------------------
>
>                 Key: AMQNET-263
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-263
>             Project: ActiveMQ .Net
>          Issue Type: Test
>          Components: ActiveMQ, EMS, MSMQ, NMS, Stomp, WCF
>    Affects Versions: 1.4.0
>            Reporter: Jim Gomes
>            Assignee: Jim Gomes
>             Fix For: 1.4.0
>
>   Original Estimate: 2 hours
>          Time Spent: 3 hours, 30 minutes
>  Remaining Estimate: 0 minutes
>
> Upgrade to the latest NUnit 2.5.5 libraries and APIs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message