activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: failover network connector with embedded jetty and camel
Date Tue, 08 Jun 2010 11:01:09 GMT
Hi,

this sounds like a known problem with web console in 5.3.1

Take a look at here for a workaround
http://activemq.apache.org/web-console.html

<http://activemq.apache.org/web-console.html>Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, Jun 7, 2010 at 10:00 PM, dgd01 <dorothea_davis@homedepot.com> wrote:

>
> I have a broker with a master/slave network connector .  My issue is that
> the
> jetty embedded broker is never started, as it appears that the
>
>
>
>      <networkConnectors>
>           <networkConnector name="NC${thd.brn}0.${thd.lcp}.CPLIQA57"
>
> uri="static:(failover://(ssl://cpliqa57.homedepot.com:61620
> ,ssl://cpliqa57.homedepot.com:61621))"
>            networkTTL="6"
>            duplex="true"
>            decreaseNetworkConsumerPriority="false"
>            suppressDuplicateQueueSubscriptions="false" dynamicOnly="false">
>         </networkConnector>
>      </networkConnectors>
> ...
> ...
> ...
>    </broker>
>
>    <!--
>        Uncomment to enable Camel
>        Take a look at activemq-camel.xml for more details
>    <import resource="camel.xml"/>
>    -->
>
>    <!--
>        Enable web consoles, REST and Ajax APIs and demos
>        Take a look at activemq-jetty.xml for more details
>    -->
>    <import resource="jetty.xml"/>
> </beans>
>
>
> Listening for transport dt_socket at address: 61640
> Java Runtime: Sun Microsystems Inc. 1.6.0_17 /usr/java/jre1.6.0_17
>  Heap sizes: current=7680k  free=5994k  max=506816k
>    JVM args: -Xdebug -Xnoagent -Djava.compiler=NONE
> -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=61640
>
> -Dactivemq.classpath=/opt/isv/mqm/java/lib;/opt/isv/activemq/fuse-mb/BR0/conf;/opt/isv/activemq/fuse-mb/BR0;
> -Xmx512M -Dorg.apache.activemq.UseDedicatedTaskRunner=true
> -Dorg.apache.activemq.store.kahadb.LOG_SLOW_ACCESS_TIME=1500
> -Dcom.sun.management.jmxremote=true
> -Dcom.sun.management.jmxremote.port=61650
> -Dcom.sun.management.jmxremote.authenticate=false
> -Dcom.sun.management.jmxremote.ssl=false
> -Dactivemq.home=/opt/isv/activemq/fuse-mb
> -Dactivemq.base=/opt/isv/activemq/fuse-mb/BR0
> -Dcom.sun.management.jmxremote=true
> -Dcom.sun.management.jmxremote.port=61650
> -Dcom.sun.management.jmxremote.authenticate=false
> -Dcom.sun.management.jmxremote.ssl=false -Dthd.brn=0 -Dthd.lcp=0
> ACTIVEMQ_HOME: /opt/isv/activemq/fuse-mb
> ACTIVEMQ_BASE: /opt/isv/activemq/fuse-mb/BR0
> Loading message broker from:
> xbean:file:/opt/isv/activemq/fuse-mb/BR0/conf/activemq0.xml
>  INFO | Using Persistence Adapter:
> org.apache.activemq.store.kahadb.KahaDBPersistenceAdapter@6b033450
>  INFO | JMX consoles can connect to
> service:jmx:rmi:///jndi/rmi://localhost:61660/jmxrmi
>  INFO | Replayed 1 operations from the journal in 0.015 seconds.
>  INFO | ActiveMQ 5.3.1-fuse-00-00 JMS Message Broker (BR0.QA.US.CPLIQA58)
> is
> starting
>  INFO | For help or more information please see:
> http://activemq.apache.org/
>  INFO | Listening for connections at: tcp://cpliqa58.homedepot.com:61610
>  INFO | Connector TC00.QA.CPLIQA58 Started
>  INFO | Listening for connections at: ssl://cpliqa58.homedepot.com:61620
>  INFO | Connector TC01.QA.CPLIQA58 Started
>  INFO | Establishing network connection from vm://BR0.QA.US.CPLIQA58 to
> failover://(ssl://cpliqa57.homedepot.com:61620,ssl://
> cpliqa57.homedepot.com:61621)
>  INFO | Connector vm://BR0.QA.US.CPLIQA58 Started
> ~
>
> The broker just waits here... it seems like it's waiting for the slave
> broker to respond before moving on to the rest of the activemq.xml ...after
> the </broker>
>
>
> when I change the network connector by removing the failaover parts then
> the
> jetty components start up fine
>
>            uri="static://(ssl://cpliqa57.homedepot.com:61620)"
>
> Is it possible to use the embedded console via jetty when failover is
> configured on the network connectors?
>
> Please let me know if you need additional detail.
>
> THANKS for your help!
>
>
> --
> View this message in context:
> http://old.nabble.com/failover-network-connector-with-embedded-jetty-and-camel-tp28810011p28810011.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message