activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Max UNGER (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-2768) HTTPS transportConnector does not create a SssSocket but a plain text one
Date Tue, 08 Jun 2010 12:46:51 GMT
HTTPS transportConnector does not create a SssSocket but a plain text one
-------------------------------------------------------------------------

                 Key: AMQ-2768
                 URL: https://issues.apache.org/activemq/browse/AMQ-2768
             Project: ActiveMQ
          Issue Type: Bug
          Components: Connector
    Affects Versions: 5.3.2
         Environment: Windows, in a Spring Based app, already embedding another Jetty server
for app GUI, and embedding ActiveMQ.
            Reporter: Max UNGER
            Priority: Blocker


Trying to enable HTTPS transportConnector in activemq.xml file, it is impossible to make it
communicate in SSL.

I added the line:
<transportConnector name="https" uri="https://localhost:8443" enableStatusMonitor="true"/>


in the activemq.xml file,

and i can see at startup that a plain text socket seem to have been created, instead of a
ssl one:

14:36:23,119  INFO org.mortbay.log.Slf4jLog 67 <main> Started SocketConnector@localhost:8443
14:36:23,119  INFO org.apache.activemq.broker.TransportConnector 250 <main> Connector
https Started
14:36:23,119  INFO org.mortbay.log.Slf4jLog 67 <main> jetty-6.1.22

When i connect with a https client (based on Spring JmsTemplate class), i cannot connect.
I have to mention also that i can successfully connect using ssl connection (so the certificates
are OK) and also in HTTP.

Thanks a lot for your work!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message