activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-2743) Pure master/slave configuration will not failover to slave when master fails
Date Thu, 20 May 2010 04:48:18 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2743?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bruce Snyder updated AMQ-2743:
------------------------------

    Attachment: activemq-brokerA.xml
                activemq-brokerB-master.xml
                activemq-brokerB-slave.xml

Attaching the three config files needed to reproduce the problem. 

> Pure master/slave configuration will not failover to slave when master fails 
> -----------------------------------------------------------------------------
>
>                 Key: AMQ-2743
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2743
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.3.1
>            Reporter: Bruce Snyder
>         Attachments: activemq-brokerA.xml, activemq-brokerB-master.xml, activemq-brokerB-slave.xml
>
>
> When using a pure/master slave configuration in ActiveMQ 5.3.1 and the master is killed,
the failover to the slave never takes place. 
> Below is a description of the topology being used: 
> * The producer sends messages to brokerA 
> * BrokerA has a uni-directional network connection using the failover transport to brokerB-master
and brokerB-slave 
> * BrokerB-master and brokerB-slave each have a uni-directional network connection using
failover to brokerA 
> * The consumer uses a failover connection to brokerB-master and brokerB-slave 
> Below are the steps to reproduce the problem: 
> # In terminal one, start up brokerA 
> # In terminal two, start up brokerB-master 
> # In terminal three, start up brokerB-slave 
> # In terminal four, start up the consumer that connects to brokerB-master and brokerB-slave
 
> # In terminal five, startup the producer that connects to brokerA to send messages 
> # In terminal two, kill brokerB-master 
> # Notice that the producer will continue sending messages until producer flow control
kicks in and blocks the send operation, but brokerB-slave never takes over 
> I copied the same exact configuration files over to instances of ActiveMQ 5.3.0 and it
works without a problem. There must be something in ActiveMQ 5.3.1 that is causing this issue.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message