activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: [VOTE] Release Apache.NMS.ActiveMQ 1.3.0
Date Wed, 19 May 2010 17:32:48 GMT
On Wed, 2010-05-19 at 09:35 -0700, magellings wrote:
> Hey Tim.  I downloaded NMS 1.3 from your link and didn't run into the
> exception mentioned here.  So official should be okay, but something is up
> with trunk.  You can still run the console attached in issue 251 to see it.
> 
> So I'll take back the -1.  Our unit and integration tests all passed as
> expected.  I'll be running this through our stress tests now.
> 

Ok, will see if I can replicate it once I have some free time.  If any
of these can be distilled down to NUnit tests it would be good to do it
that way so we can incorporate them into the test suite to avoid any
regressions.  

I regards to the dependencies issues you had what I would like to do in
future releases is include the dependencies in the associated binary
archive instead of forcing people to go find the right versions,
probably something we can do in 1.4.0.

Regards


> 
> magellings wrote:
> > 
> > I ended up downloading it from trunk and compiled the version myself.
> > 
> > I did run into an exception.  Reported here: 
> > https://issues.apache.org/activemq/browse/AMQNET-251
> > 
> > -1
> > 
> > 
> > Timothy Bish wrote:
> >> 
> >> On Wed, 2010-05-19 at 07:51 -0700, magellings wrote:
> >>> Would like to run this version through our unit tests as well as our
> >>> stress
> >>> tests but can't.  It's built against a version of the base NMS of which
> >>> you
> >>> didn't distribute.  To avoid this in the future we should consider
> >>> bundling
> >>> all dependent assemblies into an ext_bin or lib directory residing in
> >>> the
> >>> Apache.NMS.ActiveMQ solution.  Then commit them to source so the product
> >>> can
> >>> always be compiled.  Then testers can just download the source and
> >>> they'd
> >>> have the base NMS dll.
> >>> 
> >>> Error	1	Assembly 'Apache.NMS.ActiveMQ, Version=1.3.0.1962,
> >>> Culture=neutral,
> >>> PublicKeyToken=82756feee3957618' uses 'Apache.NMS, Version=1.3.0.1959,
> >>> Culture=neutral, PublicKeyToken=82756feee3957618' which has a higher
> >>> version
> >>> than referenced assembly 'Apache.NMS, Version=1.3.0.1955,
> >>> Culture=neutral,
> >>> PublicKeyToken=82756feee3957618'
> >>> c:\WIP\quadnmsv1_3\ext_bin\Apache.NMS.ActiveMQ.dll	NMS
> >>> 
> >> 
> >> You can download the NMS API release binaries from here:
> >> http://activemq.apache.org/nms/activemq-net-130-release.html
> >> 
> >> 
> >>> 
> >>> 
> >>> Timothy Bish wrote:
> >>> > 
> >>> > Hello
> >>> > 
> >>> > This is a call for a vote on the release of Apache.NMS.ActiveMQ
> >>> v1.3.0.
> >>> > 
> >>> > This version provides some much requested new feature like SSL support
> >>> > and support for the QueueBrowser.  
> >>> > 
> >>> > Changes in this version include:
> >>> > 
> >>> > * Fully implemented QueueBrowser functionality.
> >>> > * Ability to specify the socket binding on the URI
> >>> > * SSL Transport to provide secure connections.
> >>> > * Other bug fixes for issues found since v1.2.0
> >>> > 
> >>> > The binaries and source bundles for the Release Candidate can be found
> >>> > here:
> >>> > <http://people.apache.org/~tabish/nms-1.3.0-RC1/>
> >>> > 
> >>> > The Wiki Page for this release is here:
> >>> > <http://activemq.apache.org/nms/activemq-net-130-release.html>
> >>> > 
> >>> > Please cast your votes (the vote will be open for 72 hrs):
> >>> > 
> >>> > [ ] +1 Release the source as Apache NMS.ActiveMQ 1.3.0
> >>> > [ ] -1 Veto the release (provide specific comments)
> >>> > 
> >>> > Here's my +1
> >>> > 
> >>> > Regards,
> >>> > Tim 
> >>> > 
> >>> > 
> >>> > 
> >>> > 
> >>> 
> >> 
> >> 
> >> 
> >> 
> > 
> > 
> 

-- 
Tim Bish

Open Source Integration: http://fusesource.com
ActiveMQ in Action: http://www.manning.com/snyder/

Follow me on Twitter: http://twitter.com/tabish121
My Blog: http://timbish.blogspot.com/


Mime
View raw message