activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ee7arh <andrew.hu...@2e-systems.com>
Subject Re: Unable to build ActiveMQ 5.3.0 source - A required class is missing
Date Wed, 14 Apr 2010 15:30:51 GMT

Hi, thanks, I got it working now.

I ended up deleting all of the .m2/repository since just deleting those too
caused a FATAL error for some reason but after downloading them all again
along with the patch in the pom.xml did the trick.

[INFO] Reactor Summary:
[INFO]
------------------------------------------------------------------------
[INFO] ActiveMQ .............................................. SUCCESS
[8:52.519s]
[INFO] ActiveMQ :: KahaDB .................................... SUCCESS
[1:19.764s]
[INFO] ActiveMQ :: JAAS ...................................... SUCCESS
[2:03.724s]
[INFO] Openwire Generator .................................... SUCCESS
[58.407s]
[INFO] ActiveMQ :: jmdns 1.0 ................................. SUCCESS
[0.774s]
[INFO] ActiveMQ :: Core ...................................... SUCCESS
[5:03.060s]
[INFO] ActiveMQ :: RA ........................................ SUCCESS
[22.639s]
[INFO] ActiveMQ :: Pool ...................................... SUCCESS
[18.672s]
[INFO] ActiveMQ :: Camel ..................................... SUCCESS
[2:13.360s]
[INFO] ActiveMQ :: Console ................................... SUCCESS
[0.839s]
[INFO] ActiveMQ :: Optional .................................. SUCCESS
[46.794s]
[INFO] ActiveMQ :: Jar Bundle ................................ SUCCESS
[22.034s]
[INFO] ActiveMQ :: File Server ............................... SUCCESS
[25.512s]
[INFO] ActiveMQ :: RAR ....................................... SUCCESS
[9.050s]
[INFO] ActiveMQ :: Run Jar ................................... SUCCESS
[0.140s]
[INFO] ActiveMQ Tooling ...................................... SUCCESS
[0.050s]
[INFO] ActiveMQ :: Memory Usage Test Plugin .................. SUCCESS
[1:20.297s]
[INFO] ActiveMQ :: Performance Test Plugin ................... SUCCESS
[1.358s]
[INFO] ActiveMQ :: StartUp Plugin ............................ SUCCESS
[11.975s]
[INFO] ActiveMQ :: Web ....................................... SUCCESS
[22.267s]
[INFO] ActiveMQ :: Web Demo .................................. SUCCESS
[5.152s]
[INFO] ActiveMQ :: XMPP ...................................... SUCCESS
[1:23.735s]
[INFO] ActiveMQ :: Web Console ............................... SUCCESS
[39.738s]
[INFO] ActiveMQ :: Assembly .................................. SUCCESS
[6:30.334s]
[INFO]
------------------------------------------------------------------------
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 35 minutes 40 seconds
[INFO] Finished at: Wed Apr 14 17:28:22 CEST 2010
[INFO] Final Memory: 140M/307M
[INFO]
------------------------------------------------------------------------


Many thanks
ANdrew


Gary Tully wrote:
> 
> you need to remove the offending jars from your local maven repo so they
> get
> downloaded correctly the next time. The problem is that the redirection
> was
> not followed so the jars contain the text of the referral. Have a peel at
> the jars to confirm.
> 
> Can't recall for sure but I think something like
>  removing ~/.m2/repository/com/sun/xml/bind/jaxb-xjc/
> and  ~/.m2/repository/org/jvnet/jaxb2 will suffice.
> 
> 
> 
> 
> On 14 April 2010 14:56, ee7arh <andrew.hurst@2e-systems.com> wrote:
> 
>>
>> Thanks for suggestion but I already tried this since it was what you
>> suggested in a similar post which I have included for reference above.
>>
>> So right now this patch is applied and I no longer get a failure to
>> CHECKSUM
>> but it fails instead in a different way:
>>
>> A required class is missing: com/sun/tools/xjc/ErrorReceiver
>>
>> I have attached my pom.xml file for reference:
>> http://old.nabble.com/file/p28242896/pom.xml pom.xml
>>
>> The only other piece of info I have is that I zipped up the
>> activemq-5.3.0
>> folder and copied to a colleague who runs Ubuntu operating system. He
>> already had Maven installed and it built ok for him. So I am wondering if
>> it
>> is environment related but can't think what or why
>>
>> Thanks
>> Andrew
>>
>>
>> Gary Tully wrote:
>> >
>> > you need http://svn.apache.org/viewvc?view=revision&revision=924886
>> >
>> > see:
>> http://www.mail-archive.com/commits@activemq.apache.org/msg07282.html
>> > for
>> > some detail
>> >
>> > On 14 April 2010 13:55, ee7arh <andrew.hurst@2e-systems.com> wrote:
>> >
>> >>
>> >> Hello,
>> >>
>> >> I have tried for a quite a while to get ActiveMQ 5.3 to build using
>> Maven
>> >> but always run into the following problem even though I have installed
>> >> the
>> >> patch as suggested in a previous post:
>> >>
>> >> http://svn.apache.org/viewvc?view=revision&revision=881433 Link to the
>> >> POM
>> >> patch
>> >>
>> >>
>> >>
>> http://old.nabble.com/BUILD-Error-%28Unable-to-find-the-mojo%29-ActiveMQ-5.3.0-ts26876104.html#a26876104
>> >> Older post with similar problem
>> >>
>> >> I am building the project on a Mac OS x system which uses java:
>> >>
>> >> java version "1.6.0_17"
>> >> Java(TM) SE Runtime Environment (build 1.6.0_17-b04-248-10M3025)
>> >> Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01-101, mixed mode)
>> >>
>> >>
>> >> However I am not sure that this is related.
>> >>
>> >> I run following command:
>> >>
>> >> mvn clean install -Dmaven.test.skip=true
>> >>
>> >> but the build fails with the following report when compiling XMPP.
>> >>
>> >> I need to compile ActiveMQ 5.3 since I need a patch which will not be
>> >> available until 5.4
>> >>
>> >> Thanks for any assistance
>> >> Andrew
>> >>
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [INFO] Building ActiveMQ :: XMPP
>> >> [INFO]    task-segment: [clean, install]
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [INFO] [clean:clean {execution: default-clean}]
>> >> [INFO] [enforcer:enforce {execution: default}]
>> >> [WARNING] POM for 'org.apache.maven:maven-settings:pom:2.0.4:runtime'
>> is
>> >> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> [WARNING] POM for 'org.apache.maven:maven-profile:pom:2.0.4:runtime'
>> is
>> >> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> [WARNING] POM for 'org.apache.maven:maven-model:pom:2.0.4:runtime' is
>> >> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> [WARNING] POM for
>> >> 'org.apache.maven:maven-artifact-manager:pom:2.0.4:runtime' is
>> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> [WARNING] POM for 'com.sun.xml.bind:jaxb-impl:pom:2.0.2:runtime' is
>> >> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> [WARNING] POM for 'com.sun.xml.bind:jaxb-xjc:pom:2.0.2:runtime' is
>> >> invalid.
>> >>
>> >> Its dependencies (if any) will NOT be available to the current build.
>> >> -----------------------------------------------------
>> >> this realm =
>> >> app0.child-container[org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.1]
>> >> urls[0] =
>> >>
>> >>
>> file:/Users/andrew/.m2/repository/org/jvnet/jaxb2/maven2/maven-jaxb2-plugin/0.1/maven-jaxb2-plugin-0.1.jar
>> >> urls[1] =
>> >>
>> >>
>> file:/Users/andrew/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/plexus-utils-1.1.jar
>> >> urls[2] =
>> >>
>> >>
>> file:/Users/andrew/.m2/repository/com/sun/xml/bind/jaxb-impl/2.0.2/jaxb-impl-2.0.2.jar
>> >> urls[3] =
>> >>
>> >>
>> file:/Users/andrew/.m2/repository/com/sun/xml/bind/jaxb-xjc/2.0.2/jaxb-xjc-2.0.2.jar
>> >> Number of imports: 10
>> >> import: org.codehaus.classworlds.Entry@a6c57a42
>> >> import: org.codehaus.classworlds.Entry@12f43f3b
>> >> import: org.codehaus.classworlds.Entry@20025374
>> >> import: org.codehaus.classworlds.Entry@f8e44ca4
>> >> import: org.codehaus.classworlds.Entry@92758522
>> >> import: org.codehaus.classworlds.Entry@ebf2705b
>> >> import: org.codehaus.classworlds.Entry@bb25e54
>> >> import: org.codehaus.classworlds.Entry@bece5185
>> >> import: org.codehaus.classworlds.Entry@3fee8e37
>> >> import: org.codehaus.classworlds.Entry@3fee19d8
>> >>
>> >>
>> >> this realm = plexus.core
>> >> urls[0] =
>> file:/Applications/apache-maven-2.2.1/lib/maven-2.2.1-uber.jar
>> >> Number of imports: 10
>> >> import: org.codehaus.classworlds.Entry@a6c57a42
>> >> import: org.codehaus.classworlds.Entry@12f43f3b
>> >> import: org.codehaus.classworlds.Entry@20025374
>> >> import: org.codehaus.classworlds.Entry@f8e44ca4
>> >> import: org.codehaus.classworlds.Entry@92758522
>> >> import: org.codehaus.classworlds.Entry@ebf2705b
>> >> import: org.codehaus.classworlds.Entry@bb25e54
>> >> import: org.codehaus.classworlds.Entry@bece5185
>> >> import: org.codehaus.classworlds.Entry@3fee8e37
>> >> import: org.codehaus.classworlds.Entry@3fee19d8
>> >> -----------------------------------------------------
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [ERROR] BUILD ERROR
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [INFO] Internal error in the plugin manager executing goal
>> >> 'org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.1:generate': Unable to
>> load
>> >> the
>> >> mojo 'org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.1:generate' in the
>> >> plugin
>> >> 'org.jvnet.jaxb2.maven2:maven-jaxb2-plugin'. A required class is
>> missing:
>> >> com/sun/tools/xjc/ErrorReceiver
>> >> com.sun.tools.xjc.ErrorReceiver
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [INFO] For more information, run Maven with the -e switch
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> [INFO] Total time: 4 minutes 37 seconds
>> >> [INFO] Finished at: Wed Apr 14 14:43:20 CEST 2010
>> >> [INFO] Final Memory: 115M/258M
>> >> [INFO]
>> >>
>> ------------------------------------------------------------------------
>> >> --
>> >> View this message in context:
>> >>
>> http://old.nabble.com/Unable-to-build-ActiveMQ-5.3.0-source---A-required-class-is-missing-tp28242207p28242207.html
>> >> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>> >>
>> >>
>> >
>> >
>> > --
>> > http://blog.garytully.com
>> >
>> > Open Source Integration
>> > http://fusesource.com
>> >
>> >
>>
>> --
>> View this message in context:
>> http://old.nabble.com/Unable-to-build-ActiveMQ-5.3.0-source---A-required-class-is-missing-tp28242207p28242896.html
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source Integration
> http://fusesource.com
> 
> 

-- 
View this message in context: http://old.nabble.com/Unable-to-build-ActiveMQ-5.3.0-source---A-required-class-is-missing-tp28242207p28244245.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message