activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcin Giedz (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-2657) temp-queue - no producer, no consumer -> messagecount
Date Thu, 18 Mar 2010 22:13:46 GMT
temp-queue - no producer, no consumer -> messagecount 
------------------------------------------------------

                 Key: AMQ-2657
                 URL: https://issues.apache.org/activemq/browse/AMQ-2657
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.3.1
            Reporter: Marcin Giedz
            Priority: Blocker


HI,

I tried the latest snapshot 12.03.2010, several producers and consumers. No matter what I
change in activemq.xml file I always end up with memorylimit and broker is "frozen". However
today I found one really strange thing. Maybe this is something wrong with what JMX says but:
several temp-queues with  ConsumerCount=0, ProducerCount=0 but EnqueueCount was getting up
and up and Dequeue was 0 all the time . This way MemoryPercentageUsage got to 100% and AMQ
said again something like this:

2010-03-16 15:02:28,455 | INFO  | Usage Manager Memory Limit reached on temp-queue://e0499daa-604e-227c-57c5-8a700a83d690:0.
Producers will be throttled to the rate at which messages are removed from this destination
to prevent flooding it. See http://activemq.apache.org/producer-flow-control.html for more
info | org.apache.activemq.broker.region.Queue | ActiveMQ Transport: tcp:///127.0.0.1:46737


My config file is attached. All producers and consumers use CMS -3.0.1. and 3.1.1.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message