activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Closed: (AMQ-2637) More flexible osgi import version ranges
Date Fri, 05 Mar 2010 19:45:44 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2637?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Jencks closed AMQ-2637.
-----------------------------

    Resolution: Fixed

rev 919561

> More flexible osgi import version ranges
> ----------------------------------------
>
>                 Key: AMQ-2637
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2637
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.4.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 5.4.0
>
>
> In geronimo we need a little wider version ranges in the osgi import-package headers.
 For now I'm going to use a bnd pattern [==,+)  that goes from the current minor import version
to the next major version.  I'm also including configuration that will work with the next
maven-bundle-plugin so that implemented packages have a smaller version range [==,=+) that
goes to the next minor version (this is what is used everywhere now).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message