activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ying (JIRA)" <>
Subject [jira] Created: (AMQ-2614) After failover some messages are stuck in the new broker
Date Wed, 17 Feb 2010 19:30:40 GMT
After failover some messages are stuck in the new broker

                 Key: AMQ-2614
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 5.3.0
         Environment: solaris 10
            Reporter: ying
            Priority: Blocker
             Fix For: 5.4.0

1. I have 2 pair of master/slave, broker1/slave1, broker2/slave2
2. I start 4 consumer on Queue A for failover using broker1 and broker2, make it to consume
a message, commit the session and pause 500ms
3. I start 1 producer to publish 1000 messages on the Queue A
4. after consumer consumes some message, i do broker1's connector stop, not broker stop, so
the consumer will failover to broker2 and all remaining messages will forward to broker2
5. After the consumer consumes all the message, there are about 235 messages that are stuck
in broker2 which the broker will not deliver to the consumer unless I restart the consumers

the things I noticed is 
1. clearing dispatched list (235) on transport interrupt output by the ActiveMQMessageConsumer
seems to match the number of messages that get stuck
2. The other thing is I notice is that these messages are actually consumed by the my consumers.

i will try to supply more details if i find more.

This happens on today's trunk r911076

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message