activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregg Saffell (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-2598) Configuring HTTP <networkConnector> with proxyHost, proxyPort results in "Invalid connect parameters: {proxyPort=nn)}" error
Date Mon, 08 Feb 2010 20:11:32 GMT
Configuring HTTP <networkConnector> with proxyHost, proxyPort results in "Invalid connect
parameters: {proxyPort=nn)}" error
----------------------------------------------------------------------------------------------------------------------------

                 Key: AMQ-2598
                 URL: https://issues.apache.org/activemq/browse/AMQ-2598
             Project: ActiveMQ
          Issue Type: Bug
          Components: Transport
    Affects Versions: 5.3.0
         Environment: Windows XP
            Reporter: Gregg Saffell
            Priority: Minor


I'm trying to set up a forwarding bridge that will connect through an http proxy (where the
proxy happens to be running on the same machine as the destination ApacheMQ instance). Per
AMQ-1099, the following should work: 

<networkConnector name="gstest-252" uri="static://(http://gstest-252:61617?proxyHost=gstest-252&amp;proxyPort=80)"
networkTTL="5"/>  

But it results in the following error at start up:

 INFO | Establishing network connection from vm://localhost to http://gstest-252
:61617?proxyHost=gstest-252&proxyPort=80&proxyHost=gstest-252&proxyPort=80)

 WARN | Could not connect to remote URI: http://gstest-252:61617?proxyHost=gstes
t-252&proxyPort=80&proxyHost=gstest-252&proxyPort=80): Invalid connect parameter
s: {proxyPort=80)}

 INFO | Network Connector gstest-252 Started

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message