activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <jira+amq...@apache.org>
Subject [jira] Updated: (AMQNET-235) ConnectionInterrupted never fired when connection breaks using Failover protocol with tcp
Date Thu, 18 Feb 2010 22:26:40 GMT

     [ https://issues.apache.org/activemq/browse/AMQNET-235?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish updated AMQNET-235:
--------------------------------

    Fix Version/s: 1.3.0
                   1.2.1

> ConnectionInterrupted never fired when connection breaks using Failover protocol with
tcp
> -----------------------------------------------------------------------------------------
>
>                 Key: AMQNET-235
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-235
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ
>    Affects Versions: 1.2.0
>         Environment: Windows XP, Windows 2003, Windows 2008 running ActiveMQ 5.2 on Ubuntu
>            Reporter: Michel Van Hoof
>            Assignee: Timothy Bish
>             Fix For: 1.2.1, 1.3.0
>
>
> While testing for connection loss, which is important in our enviroment, we noticed that
ConnectionInterrupted s not fired properly when the connection is dicsonnected
> Following tests were performed:
> Disconnect network plug -> Inactivity Monitor notices the disconnect and triggers
reconnect in the failover transport like it should, however: No ConnectionInterrupted is fired
on the connection
> Shutdown Broker -> Same result as above
> When it can reconnect to the broker ( connection restored or broker back up) it DOES
trrigger the ConnectionResumed event..

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message