activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-2480) Stomp Transport Dispatcher Fails on NPE
Date Mon, 09 Nov 2009 23:35:53 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-2480?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=55248#action_55248
] 

Ben commented on AMQ-2480:
--------------------------

Debugging this and reproduced with a breakpoint in the presumed erroneous code.  It seems
to be the getText() method of the ActiveMQTextMessage is returning null and the convertMessage
of the LegacyFrameTranslator is trying to getBytes() of the null text.

Still looking further into this.

> Stomp Transport Dispatcher Fails on NPE
> ---------------------------------------
>
>                 Key: AMQ-2480
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2480
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Transport
>    Affects Versions: 5.3.0, 5.4.0
>         Environment: Windows XP, JRE6
>            Reporter: Ben
>
> We have been using ActiveMQ 5.2 on Windows for about 6months with a relatively low message
throughput (a maximum usage 1 message every 4 seconds, nothing crazy) and it was working perfectly.
 We have several clients that connect through either an OpenWire or Stomp connection and communicate
through Queues.   
> Several days ago I started testing higher throughput (several messages/second) messaging
by publishing to a Queue from an OpenWire connection and consuming the message on a Stomp
connection.  At some point there is a failure in the Dispatcher for the Stomp connection and
my client stops receiving messages.  The OpenWire connection is unaffected and continues filling
the Queue.  I have since upgraded to ActiveMQ 5.3 because there were some issues fixed related
to Stomp connection, but still see the same issue.  The only exception is :
> Exception in thread "ActiveMQ Connection Dispatcher: /127.0.0.1:3047" java.lang.NullPointerException

>         at org.apache.activemq.transport.stomp.LegacyFrameTranslator.convertMessage(LegacyFrameTranslator.java:69)

>         at org.apache.activemq.transport.stomp.ProtocolConverter.convertMessage(ProtocolConverter.java:594)

>         at org.apache.activemq.transport.stomp.StompSubscription.onMessageDispatch(StompSubscription.java:92)

>         at org.apache.activemq.transport.stomp.ProtocolConverter.onActiveMQCommand(ProtocolConverter.java:576)

>         at org.apache.activemq.transport.stomp.StompTransportFilter.oneway(StompTransportFilter.java:56)

>         at org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:40)

>         at org.apache.activemq.broker.TransportConnection.dispatch(TransportConnection.java:1190)

>         at org.apache.activemq.broker.TransportConnection.processDispatch(TransportConnection.java:779)

>         at org.apache.activemq.broker.TransportConnection.iterate(TransportConnection.java:815)

>         at org.apache.activemq.thread.DedicatedTaskRunner.runTask(DedicatedTaskRunner.java:98)

>         at org.apache.activemq.thread.DedicatedTaskRunner$1.run(DedicatedTaskRunner.java:36)

> I thought I would also note that with the nice new "Connector" page on the admin interface
it shows the connection to my Stomp client as connected, and similarly the "Queues" page lists
the Stomp consumer on the Queue, but the pending messages just keeps growing.
> The client library we are using for the Stomp connection is from Codehaus (http://stomp.codehaus.org/C).
 Our OpenWire connection is utilizing Spring frameworks JMS library.
> I'm going to continue to look for a test case to reproduce my error. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message