activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Moulliard (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-2501) Modify Apache Camel version of the pom
Date Wed, 18 Nov 2009 13:38:52 GMT
Modify Apache Camel version of the pom
--------------------------------------

                 Key: AMQ-2501
                 URL: https://issues.apache.org/activemq/browse/AMQ-2501
             Project: ActiveMQ
          Issue Type: Improvement
            Reporter: Charles Moulliard
             Fix For: 5.4.0


The current pom of the activemq project uses 2.0 as camel version.

The issue is that when we deploy activemq-camel 5.3.0 top of servicemix 4.1.0-SNAPSHOT, we
have a classloading issue because activemq-camel bundle cannot import org.apache.camel.component.jms
package from Camel 2.1.SNAPSHOT

May I propose to change version or add a version range in the MANIFEST file generated for
activemq-camel :

The current is :

{code}
Import-Package: META-INF.services.org.apache.camel,javax.jms;version="
 [1.1,1.2)",org.apache.activemq;version="[5.3,5.4)",org.apache.activem
 q.advisory;version="[5.3,5.4)",org.apache.activemq.camel;version="[5.
 3,5.4)",org.apache.activemq.camel.component;version="[5.3,5.4)",org.a
 pache.activemq.camel.converter;version="[5.3,5.4)",org.apache.activem
 q.command;version="[5.3,5.4)",org.apache.activemq.kaha.impl.async;ver
 sion="[5.3,5.4)",org.apache.activemq.management;version="[5.3,5.4)",o
 rg.apache.activemq.spring;version="[5.3,5.4)",org.apache.activemq.tra
 nsport;version="[5.3,5.4)",org.apache.activemq.util;version="[5.3,5.4
 )",org.apache.camel;resolution:=optional;version="[2.0,2.1)",org.apac
 he.camel.component.jms;resolution:=optional;version="[2.0,2.1)",org.a
 pache.camel.impl;resolution:=optional;version="[2.0,2.1)",org.apache.
 camel.util;resolution:=optional;version="[2.0,2.1)",org.apache.common
 s.logging,org.apache.xbean.spring.context.v2;resolution:=optional,org
 .springframework.beans.factory;resolution:=optional;version="[2.5,2.6
 )",org.springframework.beans.factory.xml;resolution:=optional;version
 ="[2.5,2.6)",org.springframework.jms.connection;resolution:=optional;
 version="[2.5,2.6)",org.springframework.transaction;resolution:=optio
 nal;version="[2.5,2.6)"
{code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message