activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Ellis (JIRA)" <jira+amq...@apache.org>
Subject [jira] Issue Comment Edited: (AMQNET-197) NMS does not work with the released version of ActiveMQ 5.3.0
Date Tue, 20 Oct 2009 13:15:53 GMT

    [ https://issues.apache.org/activemq/browse/AMQNET-197?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=54845#action_54845
] 

Daniel Ellis edited comment on AMQNET-197 at 10/20/09 6:15 AM:
---------------------------------------------------------------

Attached is my NMS test app which can reproduce the issue:-

1. Edit 'nmsprovider-test.config' and point to your broker
2. Start TestActiveMQ.exe
3. Click Connection->Connect
4. Click Connection->Start
5. Wait at least 1 minute.

An error dialog will appear with the exception raised.  (Or monitor the log at the bottom
if you have configured the config file to use the failover transport).

      was (Author: danellisuk):
    Attached is my NMS test app which can reproduce the issue:-

1. Edit 'nmsprovider-test.config' and point to your broker
2. Start TestActiveMQ.exe
3. Click Connection->Connect
4. Wait at least 1 minute.

An error dialog will appear with the exception raised.  (Or monitor the log at the bottom
if you have configured the config file to use the failover transport).
  
> NMS does not work with the released version of ActiveMQ 5.3.0
> -------------------------------------------------------------
>
>                 Key: AMQNET-197
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-197
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ
>    Affects Versions: 1.1.0, 1.2.0
>         Environment: ActiveMQ 5.3 .NET 2.0 on Windows
>            Reporter: Daniel Ellis
>            Assignee: Timothy Bish
>            Priority: Critical
>         Attachments: ActiveMQ-Test.zip
>
>
> The NMS transport disconnects after one minute when running with the latest stable release
of ActiveMQ (from http://activemq.apache.org/download.html).
> When connecting using the standard TCP transport, the exception "Unable to read beyond
the end of the stream." is raised on the exception listener.
> When connecting with the failover transport, the transport will disconnect with the same
exception coming from the trace logger.
> I have tested both the release version of NMS 1.1 as well as the latest built from trunk.
 Both work with ActiveMQ 5.2 but both fail the same way when connecting to ActiveMQ 5.3.
> Due to the timing, I suspect this is due to a keep-alive message of some kind.  Maybe
the format has changed, or a new keep alive message has been introduced?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message