activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <jira+amq...@apache.org>
Subject [jira] Commented: (AMQNET-197) NMS does not work with the released version of ActiveMQ 5.3.0
Date Tue, 20 Oct 2009 13:01:52 GMT

    [ https://issues.apache.org/activemq/browse/AMQNET-197?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=54844#action_54844
] 

Timothy Bish commented on AMQNET-197:
-------------------------------------

Its actually working as designed.  NMS doesn't have an Inactivity monitor so it doesn't send
KeepAliveInfo to the broker.  The new broker changed its configuration defaults and the KeepAliveInfo
it sends does not require a response now.  You can restore the previous behaviour by add this
option to the openwire transport uri in your activemq.xml 

{noformat}
?transport.keepAliveResponseRequired=true
{noformat}


> NMS does not work with the released version of ActiveMQ 5.3.0
> -------------------------------------------------------------
>
>                 Key: AMQNET-197
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-197
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ
>    Affects Versions: 1.1.0, 1.2.0
>         Environment: ActiveMQ 5.3 .NET 2.0 on Windows
>            Reporter: Daniel Ellis
>            Assignee: Jim Gomes
>            Priority: Critical
>         Attachments: ActiveMQ-Test.zip
>
>
> The NMS transport disconnects after one minute when running with the latest stable release
of ActiveMQ (from http://activemq.apache.org/download.html).
> When connecting using the standard TCP transport, the exception "Unable to read beyond
the end of the stream." is raised on the exception listener.
> When connecting with the failover transport, the transport will disconnect with the same
exception coming from the trace logger.
> I have tested both the release version of NMS 1.1 as well as the latest built from trunk.
 Both work with ActiveMQ 5.2 but both fail the same way when connecting to ActiveMQ 5.3.
> Due to the timing, I suspect this is due to a keep-alive message of some kind.  Maybe
the format has changed, or a new keep alive message has been introduced?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message