activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-1759) ActiveMQ 4.1.2 packaged with geronimo-jms_1.1_spec-1.1.1.jar that is not Java 1.4 compatible
Date Fri, 04 Sep 2009 18:53:12 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-1759?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Davies updated AMQ-1759:
----------------------------

    Fix Version/s:     (was: 4.1.3)
                   5.4.0

> ActiveMQ 4.1.2 packaged with geronimo-jms_1.1_spec-1.1.1.jar that is not Java 1.4 compatible
> --------------------------------------------------------------------------------------------
>
>                 Key: AMQ-1759
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1759
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 4.1.2
>            Reporter: ajbanck
>            Priority: Critical
>             Fix For: 5.4.0
>
>
> 4.1.2 is build/delivered with geronimo-jms_1.1_spec-1.1.1.jar is build with 1.5 (Java
5) This version is not 1.4 compatible, using ActiveMQ 4.1.2 on a 1.4 JVM throws exception:
> [ERROR] java.lang.UnsupportedClassVersionError: javax/jms/Message (Unsupported major.minor
version 49.0)
> 4.1.1 used geronimo-jms_1.1_spec-1.0.jar that is compiled with 1.4
> As I understand JVM 1.4 support is dropped in 5.x, not 4.x

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message