activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor Katkov (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-2259) network of brokers - pending messages not getting forwarded
Date Thu, 18 Jun 2009 20:11:35 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-2259?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Igor Katkov resolved AMQ-2259.
------------------------------

    Resolution: Won't Fix

Missconfiguration

Please use duplex, networkTTL and dynamicOnly
{code}
       <networkConnector name="default-nc" uri="multicast://default" duplex="true" networkTTL="100"
dynamicOnly="true"/>
{code}

> network of brokers - pending messages not getting forwarded
> -----------------------------------------------------------
>
>                 Key: AMQ-2259
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2259
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.2.0
>            Reporter: madderla prem kumar
>
> Hi ,
>     Am having an issue with network of brokers where in the pending messages are not
getting forwarded . Here is the scenario .
>   I have two brokers configured in network AMQ1 and AMQ2. I have defined a virtual topic
Virtual.A 
> STEP 1)  Publisher is publishing 10 messages on AMQ1 and AMQ2 has a consumer to the virtual
queue Consumer.X.Virtual.A with a selector that matches half the messages  (5 messages) published
, and the web console correctly shows 5 pending messages.
> STEP 2) Now I bring up a consumer Consumer.X.virtual.A on AMQ1 (with out restarting the
broker) , this time with a selector matching the remaining pending messages . I have left
it running for a while and dint see any messages getting forwarded from AMQ2 to AMQ1 . (am
not using conduit subscription and my networkTTL is set to 5 with dynamicOnly set to true)
> STEP 3) But when i restart AMQ1 , I see all messages forwarded from AMQ2 to AMQ1.
> Am I missing some configuration here ?
> Have another question on web console as well .
> After STEP 1 on AMQ1 I see Messages sent and Messages received set to 10 and on AMQ2
messages sent was 10 and messages received was 5 while pending messages were 5 .
> Why would AMQ1 show it as 10 for both receive and sent , Should i be reading it as messages
received and messages forwarded.
> I greatly appreciate your response .
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message