activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQCPP-232) OpenWire encode and decode UTF8 incorrect
Date Fri, 03 Apr 2009 03:02:34 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-232?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=51008#action_51008
] 

Timothy Bish commented on AMQCPP-232:
-------------------------------------

I won't get to this until tomorrow or sat, so feel free to augment the existing CPPUnit test
for the code and attach that patch as well.  :)

Thanks for the contribution.

> OpenWire encode and decode UTF8 incorrect
> -----------------------------------------
>
>                 Key: AMQCPP-232
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-232
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: Openwire
>    Affects Versions: 2.2.5
>         Environment: Windows XP SP 3, Visual Studio 2008
>            Reporter: Peter Pfort
>            Assignee: Timothy Bish
>             Fix For: 2.2.6, 3.0
>
>         Attachments: OpenwireStringSupport.patch, OpenwireStringSupport_fixed.patch
>
>
> Hallo,
> we are using topic messages to sent messages from one user to another. Our program subscribe
a durable consumer with selector "UserName='<user>'" and send a message with the property
"UserName" and value "<user>".
> All works fine, when <user> contains only ASCII characters. When <user> contains
non ASCII characters like äöüßé, the message is not send to the
>  consumer.
> The problem ist that readString and writeString in OpenwireStringSupport.cpp have bugs
> Regards,
> Peter

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message