activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frans Slothouber <>
Subject Re: Can't get mvn gram:gram to work
Date Wed, 11 Mar 2009 11:48:33 GMT
Turned out that the information about how to generate these files that
I found on the mailing list and in the source code is a bit out of date.

One way to generate the openwire implementation for C is:

    svn co activemq
    cd activemq
    cd  activemq-openwire-generator/
    mvn -Dtest=false -DfailIfNoTests=false install
    cd ../activemq-core

replace in the pom.xml the following
    <taskdef name="generate"
       classpathref="maven.compile.classpath" />
    <generate version="5" basedir="${basedir}" />
    <taskdef name="generate"
       classpathref="maven.compile.classpath" />
   <generate version="2" />
and run

    mvn generate-sources antrun:run -P openwire-generate

The sources are now in:

Have fun,

2009/3/9 Frans Slothouber <>:
> Greetings,
> I am trying to get openwire-c to work again with the current version
> of activemq.
> Got it to connect to my broker and negotiate the wireformat and send a single
> message.   For that I had to make some modifications to the generated openwire
> .h and .c files in openwire-c.
> So guessing they might be out-of-date I tried to generate them using the latest
> version of activemq sources.
> I did a:
>  svn co activemq
>  export MAVEN_OPTS=-Xmx800m
>  cd activemq
>  mvn -Dtest=false -DfailIfNoTests=false clean install
>  svn co
> maven-gram-plugin
>  cd maven-gram-plugin/
>  mvn instal
> Which built fine.
> However running
> But I just build and installed the pluging.
> What am I doing wrong?
> Frans.

View raw message