activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frans Slothouber <frans.slothou...@gmail.com>
Subject Can't get mvn gram:gram to work
Date Sun, 08 Mar 2009 23:39:47 GMT
Greetings,

I am trying to get openwire-c to work again with the current version
of activemq.
Got it to connect to my broker and negotiate the wireformat and send a single
message.   For that I had to make some modifications to the generated openwire
.h and .c files in openwire-c.

So guessing they might be out-of-date I tried to generate them using the latest
version of activemq sources.

I did a:
  svn co https://svn.apache.org/repos/asf/activemq/trunk activemq
  export MAVEN_OPTS=-Xmx800m
  cd activemq
  mvn -Dtest=false -DfailIfNoTests=false clean install

  svn co https://svn.apache.org/repos/asf/activemq/maven-plugins/trunk
maven-gram-plugin
  cd maven-gram-plugin/
  mvn instal

Which built fine.


However running

 cd ..activemq-openwire-generator/
 mvn install
 cd ../activemq-core/
 mvn gram:gram

Results in:

[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'gram'.
[INFO] org.apache.maven.plugins: checking for updates from apache.snapshots
[INFO] org.codehaus.mojo: checking for updates from apache.snapshots
[INFO] snapshot
org.apache.activemq.protobuf:activemq-protobuf:1.0-SNAPSHOT: checking
for updates from apache.snapshots
[INFO] snapshot
org.apache.activemq.protobuf:activemq-protobuf-pom:1.0-SNAPSHOT:
checking for updates from apache.snapshots
[INFO] artifact org.apache.maven.plugins:maven-gram-plugin: checking
for updates from apache.snapshots
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-gram-plugin' does
not exist or no valid version could be found
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6 seconds
[INFO] Finished at: Mon Mar 09 00:11:45 CET 2009
[INFO] Final Memory: 15M/125M
[INFO] ------------------------------------------------------------------------

But I just build and installed the pluging.
What am I doing wrong?


Frans.

Mime
View raw message