activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQCPP-232) OpenWire encode and decode UTF8 incorrect
Date Thu, 26 Mar 2009 17:39:43 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-232?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=50834#action_50834
] 

Timothy Bish commented on AMQCPP-232:
-------------------------------------

When attaching a fix its much nicer if you could attach a patch file as its easier to apply
to the different branches of code, also I can't do anything until you resubmit your patch
and select to grant the code to the ASF license.

> OpenWire encode and decode UTF8 incorrect
> -----------------------------------------
>
>                 Key: AMQCPP-232
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-232
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: Openwire
>    Affects Versions: 2.2.5
>         Environment: Windows XP SP 3, Visual Studio 2008
>            Reporter: Peter Pfort
>            Assignee: Timothy Bish
>         Attachments: OpenwireStringSupport.cpp
>
>
> Hallo,
> we are using topic messages to sent messages from one user to another. Our program subscribe
a durable consumer with selector "UserName='<user>'" and send a message with the property
"UserName" and value "<user>".
> All works fine, when <user> contains only ASCII characters. When <user> contains
non ASCII characters like äöüßé, the message is not send to the
>  consumer.
> The problem ist that readString and writeString in OpenwireStringSupport.cpp have bugs
> Regards,
> Peter

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message