activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kumar (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (AMQ-231) reliable:tcp://localhost Transport does not reconnect a consumer when broker failed.
Date Mon, 09 Feb 2009 12:57:02 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-231?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

kumar reopened AMQ-231:
-----------------------


I am facing same problem.
i have a single broker.
one consumer is subscribed for a topic.
consumer can receive messages on that topic.

then i manually put the broker down(simulated network failure)

after putting broker up again, i can reconnect to broker.(can see the topic available again).
i send messages on that topic
but consumer cant recieve messages on that topic.



> reliable:tcp://localhost Transport does not reconnect a consumer when broker failed.
> ------------------------------------------------------------------------------------
>
>                 Key: AMQ-231
>                 URL: https://issues.apache.org/activemq/browse/AMQ-231
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: JMS client
>    Affects Versions: 3.0
>            Reporter: Hiram Chirino
>             Fix For: 3.0
>
>
> Configured the consumer example client to use the reliable protocal using:
> $ ant -Durl=reliable:tcp://localhost:61616 -Dmax=20 consumer 
> Then I sent it 10 messages using
> $ ant -Durl=reliable:tcp://localhost:61616 producer
> The consumer received the first 10 messages.
> Then I shutdownn and restarted the broker.  And then sent it 10 more messages again.
 Waited to see if the consumer would reconnect to the broker and receive the 2nd set of 10
messages.  The consumer client never reconnected and it never received the 10 outstanding
messages.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message