activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ajitgirish <ajit_gir...@infosys.com>
Subject Facing a new issue in ActiveMq (JVM related)
Date Tue, 17 Feb 2009 07:07:22 GMT

Hi 

I am facing this JVM issue while using the latest version of AMq. Is this
related to JVM version or a compatibility issue with the AMq of JVM. PFB the
logs.

__________________________________________________________________________________________________
ERROR  | wrapper  | 2009/01/24 01:25:42 | JVM appears hung: Timed out
waiting for signal from JVM.
ERROR  | wrapper  | 2009/01/24 01:25:43 | JVM did not exit on request,
terminated
DEBUG  | wrapper  | 2009/01/24 01:25:48 | JVM already down.
DEBUG  | wrapper  | 2009/01/24 01:25:48 | Signal trapped.  Details:
DEBUG  | wrapper  | 2009/01/24 01:25:48 |   signal number=17 (SIGCHLD),
source="unknown"
DEBUG  | wrapper  | 2009/01/24 01:25:48 | Received SIGCHLD, checking JVM
process status.
STATUS | wrapper  | 2009/01/24 01:25:48 | JVM exited in response to signal
SIGKILL (9).
DEBUG  | wrapper  | 2009/01/24 01:25:48 | JVM process exited with a code of
1, however the wrapper exit code was already 1.
DEBUG  | wrapperp | 2009/01/24 01:25:48 | server listening on port 32000.
DEBUG  | wrapper  | 2009/01/24 01:25:48 | Waiting 5 seconds before launching
another JVM.
DEBUG  | wrapper  | 2009/01/24 01:25:52 | Command[0] : java
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[1] :
-Dactivemq.home=/activemq
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[2] :
-Dactivemq.base=/activemq
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[3] :
-Djavax.net.ssl.keyStorePassword=broker
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[4] :
-Djavax.net.ssl.trustStorePassword=broker
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[5] :
-Djavax.net.ssl.keyStore=/activemq/conf/broker.ks
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[6] :
-Djavax.net.ssl.trustStore=/activemq/conf/broker.ts
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[7] :
-Dorg.apache.activemq.UseDedicatedTaskRunner=true
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[8] :
-Dactivemq.host=dget-ora-00.networks.in.telstra.com.au
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[9] : -Xms32m
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[10] : -Xmx1024m
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[11] :
-Djava.library.path=/activemq/bin/linux/
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[12] : -classpath
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[13] :
/activemq/bin/wrapper.jar:/activemq/bin/run.jar
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[14] :
-Dwrapper.key=HiIyWd97Yq3M7TWP
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[15] : -Dwrapper.port=32000
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[16] :
-Dwrapper.jvm.port.min=31000
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[17] :
-Dwrapper.jvm.port.max=31999
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[18] : -Dwrapper.debug=TRUE
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[19] : -Dwrapper.pid=32000
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[20] :
-Dwrapper.version=3.2.3
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[21] :
-Dwrapper.native_library=wrapper
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[22] :
-Dwrapper.service=TRUE
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[23] :
-Dwrapper.cpu.timeout=10
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[24] : -Dwrapper.jvmid=2
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[25] :
org.tanukisoftware.wrapper.WrapperSimpleApp
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[26] :
org.apache.activemq.console.Main
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[27] : start
DEBUG  | wrapper  | 2009/01/24 01:25:55 | Command[28] :
xbean:file:/activemq/conf/sorter.xml
STATUS | wrapper  | 2009/01/24 01:25:55 | Launching a JVM...
ERROR  | wrapper  | 2009/01/24 01:26:21 | Startup failed: Timed out waiting
for a signal from the JVM.
ERROR  | wrapper  | 2009/01/24 01:26:21 | JVM did not exit on request,
terminated
DEBUG  | wrapper  | 2009/01/24 01:26:22 | JVM was only running for 29
seconds leading to a failed restart count of 1.
DEBUG  | wrapper  | 2009/01/24 01:26:22 | Waiting 5 seconds before launching
another JVM.
DEBUG  | wrapper  | 2009/01/24 01:26:23 | Signal trapped.  Details:
DEBUG  | wrapper  | 2009/01/24 01:26:23 |   signal number=17 (SIGCHLD),
source="unknown"
DEBUG  | wrapper  | 2009/01/24 01:26:23 | Received SIGCHLD, checking JVM
process status.
STATUS | wrapper  | 2009/01/24 01:26:23 | JVM exited in response to signal
SIGKILL (9).
DEBUG  | wrapper  | 2009/01/24 01:26:23 | JVM process exited with a code of
1, however the wrapper exit code was already 1.
ERROR  | wrapper  | 2009/01/24 01:26:23 | Unable to start a JVM
STATUS | wrapper  | 2009/01/24 01:26:23 | <-- Wrapper Stopped
__________________________________________________________________________________________________

Thanks in advance 
Ajit
-- 
View this message in context: http://www.nabble.com/Facing-a-new-issue-in-ActiveMq-%28JVM-related%29-tp22051786p22051786.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message